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1 Purpose

This document is intended to provide detailed instructions to 802.11 Task Group technical editors, both in the areas of mandatory procedures (e.g., draft naming, clean and redline drafts, etc), and a collection of hints and tricks for easy ways to get the jobs done.  
While there is an active “support group” for the editors, nothing has previously been written down explaining how the job gets done. As a result, there are as many ways to do things as there are editors.  This document describes one of the ways that has seemed to work.
2 Job description

The editor’s primary job is to create drafts.  These are generated in response to motions requesting them from the Task Group, and including the content that has been approved by the Task Group. Procedures for doing this are given in sections 4 through 9 of this document.
The editor’s job is NOT to write the draft himself/herself, though the editor, as a member of the Task Group, is certainly able to write submissions, offer comment resolutions, and make motions as can any other member.

Most of the editor’s work is done outside of Task Group sessions – either evenings during meeting weeks, or back at home after meetings are over.  During Task Group sessions the editor’s primary function is to verify that all submissions contain clear instructions and are implementable.  The editor is also the best qualified to detect overlapping and conflicting modifications, and bring them to the TG’s attention before they are accepted.
After a letter ballot, the comments from the voters are collected and managed in a comment resolution spreadsheet.  The job of managing this comment resolution spreadsheet may or may not be done by the editor, and opinions vary as to whether it is a good idea or not that the editor do this job. In case this additional job is done by the editor, procedures for handling comment spreadsheets are given in section 10 of this document.
3 Process overview

This section goes through the typical process that a draft follows, from the first submission being accepted to final approval, focusing on the editor’s role responding to the various motions. Also included is the handling of the comment resolution spreadsheets, though that function may be performed by someone other than the technical editor.
The job of the Task Group’s technical editor begins when the TG adopts its first submission to be included in the draft.  The procedures followed to reach this point vary with each TG (e.g., call for proposals, downselect procedures, confirmation votes, etc), but end with a motion stating:

Motion: To accept submission 05/362r1, and instruct the editor to include the text in the draft.

The editor’s job is then to produce an initial draft, D0.0.  See section 4.
Once the initial draft D0.0 has been created, the Task Group refines and extends the draft, through submissions or through internal reviews.  When a submission is being considered by the TG, it is approved through a motion such as:
Motion: To instruct the editor to include the changes given in document 05/536r5, with the exception of slide 46, in the next draft.

Or

Motion: To instruct the editor to include the resolutions given in document 05/619r0 in the next draft.

Eventually there is a motion requesting a new draft be created:
Motion: Instruct the technical editor to produce a new draft incorporating the changes that have been accepted by the Task Group.

The editor’s job is then to produce an updated draft, D0.1.  See section 5 for the procedures for making the changes to the draft, and section 6.1 for generation of a new draft pdf file.  The motion may also request a redline, comparing the new draft against a previous one; if so see section 6.2 for procedures for generating this redline pdf file.
This process repeats, with discussion and acceptance of submissions that make modifications to the draft, or with accepted resolutions in a comment spreadsheet, producing updated drafts as requested by the Task Group.  All of the drafts at this point are called D0.x (though it is sometimes a good idea to start out with a 2-digit ‘x’, e.g. D0.00, D0.01, D0.02, etc).  
Eventually the draft reaches the point of “technical completeness” (say, with D0.12). Once draft D0.12 has been generated by the editor, and made available to the Task Group members for the required four hours (see 6.4), a motion is made such as:
Motion: Believing the draft to be complete and free of unresolved technical issues, Task Group x resolves to forward 802.11x draft 0.12 to the working group for the purpose of conducting a 30-day working group letter ballot. The purpose of the working group letter ballot is to forward the draft to sponsor ballot. The text of the motion to be presented to the working will be “Move to renumber 802.11x draft 0.12 to 802.11x draft 1.0, and to authorize a 30-day Working Group Letter Ballot of 802.11x draft 1.0, asking the question “Should the 802.11x draft 1.0 be forwarded to sponsor ballot?””

The editor then generates a draft for Working Group Letter Ballot, D1.0
.  See section 6.1 for generation of the draft pdf file. There is no need for a redline version for the initial Working Group Letter Ballot.
If the draft fails to achieve 75% acceptance in the letter ballot, the process repeats, with submissions for modifications and resolutions to comments in a comment spreadsheet, generating drafts D1.1, D1.2, etc.  There is no requirement that all comments received from the voters be addressed. When the Task Group once again believes the draft has reached the point of “technical completeness”, a motion similar to the one above is made, and the editor generates a D2.0.  If the draft again fails to achieve 75% acceptance, this repeats with D2.1, D2.2, and eventually another letter ballot on D3.0. Etc.

When the draft achieves 75% acceptance in the letter ballot, the draft enters the “recirculation” phase. The procedure for the Task Group to make changes to the draft is unchanged – still through motions to accept submissions or resolutions to comments.  All comments from the voters in the letter ballot must be addressed. Intermediate drafts D1.1, D1.2, etc, may be generated as requested by the Task Group.  See section 6.1 for generation of a new draft pdf file, and section 6.2 for procedures for generating a redline pdf file (if requested).  When all comments have been resolved, a motion is made such as:
Motion: to accept document 06/1284r29 as the comment resolution of LBxxx comments.

This is combined with a motion:

Motion: Instruct the technical editor to produce a new draft incorporating the changes that have been accepted by the Task Group.

And a motion

Motion: Having addressed all comments arising from LBxxx, Task Group x resolves to forward 802.11x D1.3 to the Working Group for the purpose of conducting a 15-day working group recirculation letter ballot. The purpose of the working group recirculation letter ballot is to forward the draft to sponsor ballot. The text of the motion to be presented to the working group will be “Move to renumber 802.11x D1.3 to D2.0, and to authorize a 15-day Working Group Recirculation Letter Ballot of 802.11x D2.0, asking the question “Should the 802.11x draft 2.0 be forwarded to sponsor ballot?””

The editor then generates a draft for Working Group Letter Ballot, D2.0, and a redline draft showing the changes from D1.0. Also submitted is the comment resolution spreadsheet showing the resolutions to all of the comments from the previous letter ballot.  Note that if the motion in the Working Group plenary session passes (it has never been known to fail), there is actually no need to generate the draft D1.3.
Recirculations continue until there are no new disapprove votes on the draft, and there are no valid comments received that are associated with a disapprove vote.

Mandatory Editorial Coordiation is required before the Working Group recirculations complete.  Timing is at the discretion of the Task Group Chair. See section 7.

On completion of the final Working Group recirculation letter ballot (on, say, D6.0), a report is prepared for ExCom requesting the draft be forwarded for Sponsor Ballot. This report includes a listing of all unsatisified comments from the remaining disapprove voters, which is generated from the comment resolution spreadsheets.

Once ExCom approval has been granted, the “clean” version of D6.0 (unchanged from the last Working Group recirculation ballot) is presented for the initial Sponsor Ballot.  The initial Sponsor Ballot is a 30-day ballot.
On completion of the initial Sponsor Ballot, regardless of the acceptance percentage
, the comments from the voters are assembled into a comment resolution spreadsheet, and resolved in a similar manner to the Working Group recirculation ballots. The procedure for making changes to the draft is unchanged – still through motions to accept submissions or resolutions to comments.  All comments from the voters in the letter ballot must be addressed. Intermediate drafts D6.1, D6.2, etc, may be generated as requested by the comment resolution committee.  When all comments have been resolved, a motion is made such as:

Motion: to accept document 06/1284r29 as the comment resolution of initial/1strecirc/etc comments.

This is combined with a motion:

Motion: Instruct the technical editor to produce a new draft incorporating the changes that have been accepted.

And a motion

Motion: Move to renumber 802.11x D6.2 to D7.0, and to authorize a 10-day Sponsor Ballot Recirculation Letter Ballot of 802.11x D7.0.

The editor then generates a redline draft for Sponsor Ballot, D7.0.  See section 8. Also submitted is the comment resolution spreadsheet showing the resolutions to all of the comments from the previous letter ballot.

Recirculations continue until there are no new disapprove votes on the draft, and there are no valid comments received that are associated with a disapprove vote.

On completion of the final Sponsor recirculation letter ballot (on, say, D9.0), a report is prepared for ExCom requesting the draft be forwarded to RevCom. This report includes a listing of all unsatisified comments from the remaining disapprove voters, which is generated from the comment resolution spreadsheets.

Once ExCom approval has been granted, the FrameMaker source files for the “clean” version of D9.0 (unchanged from the last Sponsor recirculation ballot) are forwarded to RevCom. RevCom makes a recommendation to the IEEE Standards Board regarding publications. Once approved by the IEEE Standards Board, the editor prepares an “errata” sheet with editorial corrections needed prior to publication, and sends this along with the FrameMaker source and source for all figures to IEEE Publications. Details of the final steps are given in section 9.
4 Generating the initial draft D0.0 - using FrameMaker

While IEEE is willing to publish standards using either MSWord or Adobe FrameMaker, 802.11 always uses FrameMaker. It may have something to do with the problems MSWord has had in the past with big projects. It may just be inertia, with a HUGE standard already done in FrameMaker. Consider Don Quixote fighting his windmill. Some battles will never be won.
So give up and buy a copy of Adobe FrameMaker.  While the cost is several hundred dollars, it is much less than the expense associated with a single meeting (plane, hotel, registration, etc). A bigger problem is that FrameMaker may be considered an “unauthorized software application” and violate company policy by having it installed on a company computer. So a special exemption is needed as well as authorization to spend the $$.
Given that the draft will eventually need to be done in FrameMaker, it is best that the conversion from MSWord be done early (like with the initial submission accepted for D0.0).  The conversion from MSWord to FrameMaker is non-trivial, especially when there are tables and figures.  Also there is no known tool that will produce a redline comparing a pdf file generated from MSWord and a pdf file generated from FrameMaker (note that a redline is needed for a recirculation ballot).  So it is best to bite the bullet and learn FrameMaker early.

This section attempts to guide a novice through some of the complexities of FrameMaker.

It is assumed in this section that the submission being turned into D0.0:

· Properly contains all of the editing instructions needed in the amendment.

· Properly quotes all of the needed text from the base document.

· Properly numbers all of the clauses, tables, and figures.

If not, then the procedures described here need to be extended somewhat.  In particular, if the Task Group members are more comfortable writing technical papers for publication in journals, it is likely that the accepted submission will be written as such.  It would then require a certain amount of restructuring and reformatting to turn such a submission into a draft amendment.
4.1 Files and directory structure

There are three main files for each version of the draft, frontmatter.fm, body.fm, and figures.vsd. In addition, there are several other files that are generated during the process, such as redline fm files, output ps files, and output pdf files.
It is certainly possible to organize these files into a separate directory for each draft version.  It is also possible to use a Source Code Control System (SCCS). However both seem to be overkill, and a single directory containing all of the files is easier to manage. Each filename started with the draft number, e.g., D3.1-frontmatter.fm, D3.1-body.fm are the source files for draft D3.1, and D3.1.pdf is the output file.  This is the convention that will be followed in the draft generation procedures in sections 6.1, 6.2, and 8.1. People with ordinary skill in the art can adapt these FrameMaker-specific procedures to other file and directory structures as they wish.
4.2 Templates

While it is possible for you to select all the fonts, point sizes, styles for headings, page formatting, etc, etc, you really don’t want to.  IEEE provides templates for standards development that meet all of their requirements, and make life much easier.  There are two templates, one for the boilerplate (called “frontmatter”), and one for the meat (called “body”).  They were most recently updated in late 2005 or early 2006, and can be downloaded from the following URLs:

· http://standards.ieee.org/resources/spasystem/templates/framemaker7_frontmatter.fm
· http://standards.ieee.org/resources/spasystem/templates/framemaker7_body.fm

The files are also embedded in this document: 
[image: image1.emf]D0.0-frontmatter.fm

 and 
[image: image2.emf]D0.0-body.fm

. Either drag-n-drop them from here to a Windows Explorer window, or double-click them here and use “Save As” in FrameMaker to store a local copy.
One other document is invaluable: the IEEE Style Manual.  It is updated every two years, and the current version is available at:
· http://standards.ieee.org/guides/style/2007_Style_Manual.pdf
Four changes need to be made immediately to the templates: the document title, committee name, document number, and the copyright date.  
The document title for 802.11 amendments is always “Draft Standard for Information technology – <nl> Telecommunications and information exchange between systems - <nl> Local and metropolitan area networks - <nl> Specific requirements <nl>Part 11: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) specifications <nl> Amendment XX: Title of this amendment”  Note the hyphens, capitalization, and newlines – they need to match exactly the published standard (currently 802.11-2007). Where the frontmatter template says “Draft Standard for”, replace it with the complete title (and observing the formatting going crazy for all but the first line), select all of the text in the title, from “Draft” to the end of the title of the amendment, and set the style to “Title” (Format->Paragraphs->Title).  It still won’t look right, with too much space between the lines. Select all the text from “Draft” through “Local and metropolitan area networks -”, and click on Format->Paragraphs->Designer. On the “Basic” tab, change the “Space below Pgf” to 0 pt, then click “Apply”. Select the lines that start “Part 11:” and end “specifications”, and click on Format->Paragraphs->Designer. On the “Basic” tab, change the “Space below Pgf” to 20 pt, then click “Apply”. Select the line that starts “Amendment X:”, and click on Format->Paragraphs->Designer. On the “basic” tab change the “Space below Pgf” to 20 pt, then click “Apply”. Its getting close, but not quite right yet, since the disclaimer at the bottom of the page doesn’t fit on the page. Select the entire text of the title, from “IEEE” through the line that starts “Amendment X:”, and click on Format->Paragraphs->Designer. On the “Default Font” tab change the Size from 24pt to 18pt, then click “Apply”. The complete address of the IEEE Standards Activities Department should now be on the first page.  Congratulations!! You’re now an accomplished FrameMaker user!
The title on the first page of the body needs to be similarly filled in.

On the first page of the frontmatter, where the template says “Committee of the IEEE Society”, it needs to be change to “LAN/MAN Standards Committee of the IEEE Computer Society” or to “IEEE 802 Committee of the IEEE Computer Society”.

On the top line of the frontmatter, and on the line just above the title (two places), change “PXXXX” to “P802.11x” and change “D1” to “D0.0”.

On the first page of the frontmatter, where it says “Copyright c <current year>”, replace “<current year>” with the current year.

Opinions differ as to the proper contents for the disclaimer in the box on page iii of the frontmatter. The IEEE Style Guide doesn’t give any guidance for an Amendment, and the frontmatter template seems to only follow the draft standard example.  So it should either be identical to the full title of the document, or “P802.11x D0.0”.  If the latter, it needs to be kept up to date with later draft numbers,
4.3 Editing instructions

Task Groups in 802.11 write amendments to the published standard 802.11-2007. Amendments are described in clause 21 of the IEEE Style Guide, with an example in Annex C.  All amendments start with two short introductory paragraphs just after the document title on page 1 of the body:
NOTE - The editing instructions contained in this amendment define how to merge the material contained therein into the existing base standard and its amendments to form the comprehensive standard.

The editing instructions are shown in bold italic. Four editing instructions are used: change, delete, insert, and replace. Change is used to make corrections in existing text or tables. The editing instruction specifies the location of the change and describes what is being changed by using strikethrough (to remove old material) and underscore (to add new material). Delete removes existing material. Insert adds new material without disturbing the existing material. Insertions may require renumbering. If so, renumbering instructions are given in the editing instructions. Replace is used to make changes in figures or equations by removing the existing figure or equation and replacing it with a new one. Editing instructions, change markings, and this NOTE will not be carried over into future editions because the changes will be incorporated into the base standard.

To incorporate this text into the FrameMaker source file, select it from this document and copy to the clipboard.  Move the cursor to the end of the title on the first page of the body.fm, and hit enter, making a blank line between the title and the first level heading. Click Edit->PasteSpecial, then select “Text”. Select all of the text just inserted, and change it to style “Note” (Format->Paragraphs->Note). Note the words above that are in bold italic (which didn’t get copied over) – select those words and hit Ctrl-B (bold) and then Ctrl-I (italic). Select the word “strikethrough” and click on Format->Style->Strikethrough. Select the word “underscore” and hit Ctrl-U (underscore).
The remainder of the amendment consists of alternating editing instructions and content. The editing instructions are in bold italic and always begin with the word Change/Delete/Insert/Replace. The lines following the editing instructions (for Change/Insert/Replace) give the detail of what is being changed, inserted, or replaced.  When the editing instruction is Insert, the text that follows does not contain any strikethrough or underlining. When the editing instruction is Change, the text that follows contains strikethrough and/or underlining, and enough technical context quoted from the base specification to identify to the voters exactly what is being changed.

4.4 Headings

Existing headings in the base standard are only included in the amendment if their content is being modified.

For example, if a change is being made to subclause 5.4.3.4 (Key management), headings would appear in the amendment for 5, 5.4, 5.4.3, and 5.4.3.5.  If there are no other changes in clause 5, then no other headings will appear in the amendment.  The sequence of lines in the amendment would be:

5. General description

5.4 Overview of the services

5.4.3 Access control and data confidentiality services

5.4.3.4 Key management

Change the third paragraph of 5.4.3.4 as follows:

The style of the heading “General description” is “H1”, the style of the heading “Overview of the services” is “H2”, the style of the heading “Access control and data confidentiality services” is “H3”, and the style of the heading “Key management” is H4. These are all entered by simply typing the heading as normal text (without typing any of the numbers), then applying the paragraph format (e.g., Format->Paragraphs->H1).
To fix the automatic numbering (doing the actions of the above paragraph will leave Key management as 1.1.1.1), place the cursor somewhere in the heading “General description” and type Ctrl-M (or Format->Paragraphs->Designer). On the “Numbering” tab where it currently says “H:<n+>” change to “H:<n=5>”, and click “Apply”. Key management will now appear as 5.1.1.1. Similarly, place the cursor somewhere in the heading “Overview of the services” and type Ctrl-M (or Format->Paragraphs->Designer). On the “Numbering” tab where it currently says “H:<n>.<n+>” change to “H:<n>.<n=4>” and click “Apply”. Key management will now appear as 5.4.1.1. In a similar way, change the numbering for “Access control and data confidentiality services” to “H:<n>.<n>.<n=3>” and the numbering for “Key management” to “H:<n>.<n>.<n>,<n=4>”.

If there are subsequent changes being made in 5.4.3.5 (Data origin authenticity) and 5.4.3.6 (Replay detection), no changes are needed to the numbering for the headings – the “<n+>” will automatically take the next higher number after the forced “n=4” placed in the Key management heading.
When a sequence of new subclauses is added (which typically happens in 10.3), only the first needs to have an override in the numbering.  All the following headings will continue from that point onward.

When a subclause is inserted between two existing subclauses, the IEEE Style Guide specifies that a letter shall be used in the numbering.  For example, a subclause inserted between 11.4.4 and 11.4.5 is numbered 11.4.4a., and appears in the amendment as:
11. MLME

11.4 Traffic stream operation

Insert the following after 11.4.4:

11.4.4a TS setup by resource request during a fast BSS transition

As in the previous example, the style of the heading “MLME” is “H1”, the style of “Traffic stream operation” is “H2”, and the style of the heading “TS setup by resource request during a fast BSS transition” is “H3”. The numbering for heading “MLME” is changed to “H:<n=11>”, and the numbering for heading “Traffic stream operation” is changed to “H:<n>.<n=4>”. The numbering for the new heading is changed from “H:<n>.<n>,<n+>” to “H:<n>.<n>.<n=4><a=1>”.  It now appears as 11.4.4a.  If there was a subsequent subclause 11.4.4b, its numbering would be changed to “H:<n>.<n>.<n><a+>”.

4.5 Figures

Figures appear in numerous places in the base standard, and will likely appear in every amendment too.
There are three distinct ways of doing figures in FrameMaker: 1) using a Table to generate the figure, 2) importing a TIFF file from a graphics program, and 3) importing a Visio drawing.

In all three cases, the figure needs to have a caption, and the caption needs to be on the same page as the figure.  This is accomplished in FrameMaker by making a separate anchored frame for the figure. Move the cursor to the place where the figure is to be inserted, and click Special->AnchoredFrame. Set the Anchoring Position to “Below Current line”, width to 432 points (entire line width), and height to whatever seems right for this figure (432 is a good place to start, making a square box; it will be adjusted to fit later). Click “New Frame”. Now display the tools palette, which is done by clicking on the small triangle on the right edge of the FrameMaker window, just above the vertical scoll bar. On the tools palette, click the “Text frame” tool, which looks like six lines of very fine print inside a dotted box.  If the tools palette is displayed as a two-column vertical bar, it is in the sixth row on the left, adjacent to the large “A”. After clicking the “Text frame” tool, move the cursor inside the anchored frame, and the cursor turns into crosshairs. Sweep out a rectangle at the bottom of the anchored frame, as wide as the anchored frame, and enough height for one row of text. This will become the figure caption.  After releasing the mouse button, a popup window appears asking the number of columns (and the gap between columns) to make in this text frame – answer “1” and then click “Set”. Place the cursor inside this text frame, and type the figure caption (it will appear at the left margin).  Then select the text just typed, and set its paragraph style to “FigCaption” (Format->Paragraphs->FigCaption).
Figure numbers in 802.11 are of the form n-m, where n is the clause number, and m is sequentially assigned within the clause. To set the proper number format, place the cursor somewhere within the figure caption, and type Ctrl-M or click Format->Paragraphs->Designer. Changing the autonumber format from “F:Figure <n+>\m” to “F:Figure <n=7>-<n=35>\m” will set the figure number to be “7-35”.  If two new figures are inserted between Figures 7-35 and 7-36, they are numbered 7-35a and 7-35b; the autonumber format would be changed from “F:Figure <n+>\m” to “F:Figure <n>-<n><a=1>\m” for the first, and “F:Figure <n>-<n><a+>\m” for the second.  As with sub-clause numbering, usually only the first figure in an insertion block needs to have forced values; however all figures need to have the autonumber format modified to make them n-m.

Figures float in the draft, and appear somewhere near the place anchored, depending on available space on the page.  It is therefore very important that every figure be referenced in the text by number; instead of saying “as shown in the following figure” the text should be “as shown in Figure 7-8b.”

4.5.1 Using a FrameMaker Table as a figure
Many of the figures that appear in 802.11-2007 are very simple boxes and text, and used to depict the format of an information element or a field in a frame.  These can be generated completely within FrameMaker, by the use of a Table within a text frame.  As an example, the following procedure will reproduce figure 7-29 in 7.3.1.11, giving the format of the Action field (1 octet of Category, and variable octets of Action Details).

In the top portion of the anchored frame, we will create another Text frame.  Open the tools palatte and click the “Text frame” tool. Move the cursor inside the anchored frame, and sweep out a rectangle starting at the top left, as wide as the anchored frame, and nearly touching the top of the text frame containing the figure caption.  Set the number of columns to “1” and click “Set”. Place the cursor inside this new text frame.

Click on Table->InsertTable.  Set number of columns to one more than the number of items to appear in the figure (3 in this example), and number of body rows to 2. The number of heading rows and footing rows should be zero.  Click “Insert”. Place the cursor inside one of the cells of the table, and press Ctrl-T (or click Table->TableDesigner). On the “Basic” tab, change “Title Position” to “No title” and click “Apply”. Select the cells across the bottom row of the table, and click Table->CustomRulingandShading. Under “Apply Ruling Style” select “None”, and under “To Selection” check the boxes for Bottom, Left, and Right (leaving the box for Top unchecked). Click “Apply”. Select the cells on the leftmost column of the table, and click Table->CustomRulingandShading. Under “Apply Ruling Style” select “None”, and under “To Selection” check the boxes for Top, Bottom, and Left (leaving the box for Right unchecked). Click “Apply”. Select all the cells of the table, and press Ctrl-M (or click Format->Paragraphs->Designer). On the “Basic” tab, change “Alignment” to “Center” and click “Apply”. It is now ready to fill in the field names and widths.
Across the top row of the table, inside of the solid boxes, fill in the field names.  In the example of Figure 7-29 this would be “Category” and “Action details”. Across the bottom row of the table, inside of the dotted boxes, fill in the field sizes. In the example of Figure 7-29 this would be “Octets”, “1”, and “variable”.

The next step is the artistic step – make it look pretty.  The columns widths can be adjusted to allocate the 432 points across the page in any way that works. Making the column wider could use less vertical space for the text; making the column narrower allows more columns to fit on the page.  Column widths are adjusted by placing the cursor in the column desired, and clicking Table->ResizeColumns. Select “To width” and enter the desired number of points to allocate for that column (remember, 432 is the full width). Selecting cells and clicking Graphics->Rotate gives options for rotating the text, which may also be useful.
The final step is to remove the vertical white space. Move the cursor anywhere inside the text frame but outside the table, hold down the Ctrl key, and left-click.  This will select the text frame within the anchored frame. Move the cursor over the solid black spot in the center of the bottom of the text frame, and drag it up to be just below the bottom of the bottom row of the table. Move the cursor to the right of the solid black spot, but still along the dotted line of the boundary of the text frame, and drag the entire text frame up, in several steps, so that the solid line at the top of the table is just below the dotted line of the boundary of the anchored frame. Note that a portion of the text frame is actually hidden, as it is outside the limits of the anchored frame. Move the cursor into the page margin and left-click, clearing the selection of the upper text frame. Now select the lower text frame, containing the caption – point at the caption text, hold down the Ctrl key, and left-click. Move the cursor to the right of the solid black spot in the middle of the top of the text box, and drag the text box up so that it is nearly touching the upper text box. Once again move the cursor into the page margin and left-click, clearing the selection of the lower text frame. Now point the cursor at the boundary line of the bottom of the anchored frame, and left-click. Point at the solid block spot in the middle of the bottom edge of the anchored frame, and drag it upward to come close to the bottom of the text of the figure caption. Move the cursor into the page margin and left-click, clearing the selection.
That was much easier than the other two alternatives for figures.
4.5.2 Importing a graphics file as a figure

FrameMaker is capable of importing any type of drawing, and scaling it to fit inside of an anchored frame. The difficult part is making the figure legible.
The IEEE Style Guide, clause 16.1 contains lots and lots of caveats about graphics and how they appear in a published standard, and states 

· “It is important to keep in mind when preparing figures that coordination with the IEEE Standards Activities Department at the earliest stage can help ensure the most accurate and timely publication of a standard after approval. An IEEE Standards project editor should be contacted while figures are still in development.”
· “Figures created in programs that do not support vector illustrations may result in bitmapped graphics or graphics that do not translate well into other applications. The graphics may not scale appropriately or retain their quality.”

To create a figure in Visio and transfer it into the draft as a graphics file, the following procedure is used:

1) In Visio, File->PageSetup, in the “PrintSetup” tab select 8.5x11 paper; and in the “PageSize” tab select “same as paper size”

2) Keep the width of the figure below 5 3/4 inches. Edit the drawing as needed.

3) Select the entire figure with Ctrl-A. File->SaveAs, select “Save as type” to be “Tag Image File Format (*.tif)” and set the file name. Click “Save”. In the TIFF Output Options popup screen, select None for Data compression, 16-color greyscale, Resolution “Screen”, and size “Source”

4) In FrameMaker, select the anchored frame by clicking on the dotted line at its edge.

5) File->Import->File, select the file written above, and click the button for “Copy into document”. Click “Import”.  In the “Imported Graphics Scanling” popup window, select “Custom dpi” and set to 96.

6) If the bottom of the figure doesn’t appear in the anchored frame, the frame needs to be expanded.  Press “Delete” to delete the imported figure. Select the anchored frame by clicking on the dotted line at its edge. Drag the solid black box in the middle of the bottom of the frame downward, making the anchored frame larger. Its easiest to make it too large now, and remove extra space in the next step. Move the cursor into the margin and left-click to de-select the anchored frame. Move the cursor to be within the text box containing the figure caption, hold down the Ctrl key, and left click to select the text box. Drag the text box down to the bottom of the anchored frame. Move the cursor into the margin and left-click to de-select the text frame. Move the cursor to the dotted line at the edge of the anchored frame and left-click to select the anchored frame. Repeat the File->Import->File of the previous step, and this step again until the entire figure is visible in the anchored frame and doesn’t overlap with the caption.

7) With the imported graphic still selected, move the figure upward to the top of the anchored frame, and left/right as needed to make it look good. Move the cursor to the margin and left-click to de-select the graphic frame. Move the cursor to be within the text box containing the caption, hold down the Ctrl key, and left click to select the text box. Drag the text box up to the bottom of the graphic. Move the cursor into the margin and left-click to de-select the text frame. Move the cursor to the dotted line at the edige of the anchored frame and left-click to select the anchored frame. Drag the solid black box in the middoe of the bottom of the frame upward so that it is just below the caption. Move the cursor into the page margin and left-click to de-select the anchored frame.
Fortunately, the last two steps in this procedure only need to repeated if the size of the figure changes later. Mere content changes that don’t affect the size are easy to update later. See 5.3.3 for the figure update procedures.

4.5.3 Importing a Visio drawing as a figure

This method is by far easier than the previous two, but for some reason discouraged by IEEE. Their preference is for TIF files; but when the choice is between large files to obtain high resolution to eliminate the “fuzziness” and importing Visio, they relent. See IEEE Style Guide 16.1 at point (d).
To create a figure in Visio and transfer it into the draft as a graphics file, the following procedure is used:

1) In Visio, File->PageSetup, in the “PrintSetup” tab select 8.5x11 paper; and in the “PageSize” tab select “same as paper size”

2) Keep the width of the figure below 5 3/4 inches. Edit the drawing as needed.

3) Select the entire figure with Ctrl-A. Copy it to the clipboard with Ctrl-C.

4) In FrameMaker, select the anchored frame by clicking on the dotted line at its edge.

5) Paste the clipboard contents into the anchored frame with Ctrl-V.

6) There is some unexplained strange behaviour that sometimes happens here.  Sometimes the pasted figure is significantly smaller than the Visio source.  Compare the ruler at the top of the Visio window (which was used to keep the figure width below 5 ¾ inches) and the relative size in the FrameMaker window (width of the anchored frame is 6 inches). Sometimes they are about the same width, sometimes the pasted copy is abt 30% smaller. If the pasted copy is smaller, right-click inside the figure and select “Object Properties”. Calculate 432pt divided by the value shown in the Width under “Unrotated Size”, and enter the result, as a percentage, in the Scaling Percent in the middle of the dialog box.  Click “Set”. I’ve found the scale factor to usually be about 140%.
7) Drag the figure upward to the top of the anchored frame, and left/right as needed to make it centered.

8) If the bottom of the figure doesn’t appear in the anchored frame, the frame needs to be expanded.  Press “Delete” to delete the imported figure. Select the anchored frame by clicking on the dotted line at its edge. Drag the solid black box in the middle of the bottom of the frame downward, making the anchored frame larger. Its easiest to make it too large now, and remove extra space in the next step. Move the cursor into the margin and left-click to de-select the anchored frame. Move the cursor to be within the text box containing the figure caption, hold down the Ctrl key, and left click to select the text box. Drag the text box down to the bottom of the anchored frame. Move the cursor into the margin and left-click to de-select the text frame. Move the cursor to the dotted line at the edge of the anchored frame and left-click to select the anchored frame. Repeat the previous three steps (Ctrl-V, scaling, and dragging upward/centering), and this step again until the entire figure is visible in the anchored frame and doesn’t overlap with the caption.

9) With the imported graphic still selected, move the figure upward to the top of the anchored frame, and left/right as needed to make it look good. Move the cursor to the margin and left-click to de-select the graphic frame. Move the cursor to be within the text box containing the caption, hold down the Ctrl key, and left click to select the text box. Drag the text box up to the bottom of the graphic. Move the cursor into the margin and left-click to de-select the text frame. Move the cursor to the dotted line at the edige of the anchored frame and left-click to select the anchored frame. Drag the solid black box in the middoe of the bottom of the frame upward so that it is just below the caption. Move the cursor into the page margin and left-click to de-select the anchored frame.

Fortunately, the last two steps in this procedure only need to repeated if the size of the figure changes later. Mere content changes that don’t affect the size are easy to update later. See 5.3.3 for the figure update procedures.

4.6 Tables

Tables appear in numerous places in the base standard, and will likely appear in every amendment too.

Tables are generated in FrameMaker by clicking Table->InsertTable. Table Format should always be set as “IEEE format”, the number of heading rows always be set to 1, and the number of footing rows always be set to 0.  The number of rows and columns vary for the particular table being entered; while they are easy to change later, the column sizings often need to be adjusted if the column quantity changes later.

All tables (except those appearing in clause 10, Annex A, or Annex O) have table titles.  The table title appears immediately above the table.  If the table is split across pages, the table title is repeated at the top of each successive page. After setting the initial number of rows and columns, the cursor is set to enter the table title.

Table numbers in 802.11 are of the form n-m, where n is the clause number, and m is sequentially assigned within the clause. To set the proper number format, place the cursor somewhere within the table title, and type Ctrl-M or click Format->Paragraphs->Designer. Changing the autonumber format from “T:Table <n+>\m” to “T:Table <n=7>-<n=8>\m” will set the table number to be “7-8”.  If two new tables are inserted between Tables 7-8 and 7-9, they are numbered 7-8a and 7-8b; the autonumber format would be changed from “T:Table <n+>\m” to “T:Table <n>-<n><a=1>\m” for the first, and “T:Table <n>-<n><a+>\m” for the second.  As with sub-clause numbering, usually only the first table in an insertion block needs to have forced values; however all tables need to have the autonumber format modified to make them n-m.
If there is no table title (e.g. tables in clause 10, Annex A or Annex O), put the cursor somewhere inside the table and press Ctrl-T (or click Table->TableDesigner). On the “Basic” tab, set “Title Position” to “No Title” and click Apply.

Sizing of the column widths is done by clicking Table->ResizeColumns, with the cursor blinking in the text in the column to be resized. For sizing, remember that the line width is 432 points.  For tables that appear in clause 7 with frame formats, 72/80/280 appears to match the base specification. For tables that appear in clause 10 with the MLME descriptions, 100/62/120/150 appears to match the base specification.
To add rows to a table after it appears in the draft, place the curser somewhere in the row above or below where the new row(s) are to appear, and click Table->AddRowsorColumns. Select the number of new rows to add, and whether they should appear above or below the row containing the cursor. To delete rows from a table, select the entire row(s) (point cursor in top leftmost cell to delete, press left mouse button, and move mouse to the bottom rightmost cell to delete, then release the mouse button). Press “delete”, and then click “Remove Cells from Table” and “Clear”.
Tables float in the draft, and appear somewhere near the place anchored, depending on available space on the page.  It is therefore very important that every table be referenced in the text by number; instead of saying “as shown in the following table” the text should be “as shown in Table 7-8b.”
4.7 Lists

The IEEE Style Guide allows two types of lists in drafts – ordered lists and unordered lists. 

Unordered lists are always dash lists, not bullets.  To convert text to a dash list, change the paragraph style to “DL,DashedList”
Ordered lists can be up to three levels deep. The first level is always lettered, a), b), c), etc. The second level is always numbered, 1), 2), 3), etc. The third list is always lower case roman, i), ii), iii), etc. The Style Guide contains the further restriction that only a single ordered list be present in a sub-clause, making cross references to list items unique.

As with the dash list, list items are made by setting the proper paragraph style.  For each level, there are two paragraph styles – one for the first item of the list, and one for subsequent items of the list.  The paragraph styles, and the resulting list format, are:

a) L1,LetteredList or L1,NumberedList (which is identical)

b) L,LetteredList or L,NumberedList (which is identical)

1) LI1,NumberedList2

2) LI,NumberedList2

i) LII1,NumberedList3

ii) LII,NumberedList3

4.8 Master pages
So far all of the editing has been done on the FrameMaker “Body Pages.” The FrameMaker “Master Pages” contains all of the constant stuff that also appears on the page, such as headers and footers and line numbers.  For the most part, everything that we as 802.11 editors need to do is already done in the Master Pages in the template files.  Only a few minor items remain.
The frontmatter pages contain a copyright notice centered at the bottom of each page. The year needs to be kept current.  To fix the year:

1) In the frontmatter.fm window, Click on View->MasterPages.

2) Scroll through all 14 of the pages, looking at the footer of each.  Everywhere there is a copyright year, fix it. There are many.
3) Click on View->BodyPages. In the popup window, leave “Keep Overrides” checked, and click “Continue”

4) In the body.fm window, Click on View->MasterPages.

5) Scroll through all 13 of the pages, looking at the footer of each.  Everywhere there is a copyright year, fix it. There are many.

6) Click on View->BodyPages. In the popup window, leave “Keep Overrides” checked, and click “Continue”

The body pages of the draft also contain the draft name, draft number and date in one upper corner of each page. The draft number and date changes frequently, and changes to it are given in the procedures for generating a pdf output file. Setting the draft name only needs to be done once at the beginning:
1) In the body.fm window, Click on View->MasterPages

2) In the header of the first two pages, change “IEEE” to “IEEE P802.11x/D0.0, March 2008”. The templates show “Std” on the line below IEEE, which is not present in the IEEE Style Guide. Delete “Std” on the second line of the heading.
3) Click on View->BodyPages. In the popup window, leave “Keep Overrides” checked, and click “Continue”

While there is a lot more than can be done with the Master Pages, leave it for the IEEE Staff during the publication phase.

4.9 Printing
The procedures given in 6.1 are used to print the draft. These procedures cover the additional items needed, such as building the Table of Contents and Bookmarks in the output pdf file.
4.10 Numbering spreadsheet

The Editor’s group maintains an Excel spreadsheet with numbering information, and tracks the dependencies of one draft on another.  
As part of generating D0.0, the editor needs to make the additions to the numbering spreadsheet.

The purpose of this spreadsheet is twofold:

· To identify overlaps, where multiple amendments are affecting the same text

· To assign correct numbering when multiple amendments do insertions at the same point.

As of March 2008, this spreadsheet was on the document server as 11-07-2213-14-0000-ieee-802-11-2007-number-alignment-working-document.xls. In addition to the normal submission title page, and a Revision History, this spreadsheet contains pages for clauses, definitions, figures, tables, and MIB entries.  The page for clauses will be described in some depth; the others are similar and only briefly described.

On the page named “clauses” there is a row for each clause – whether the clause exists in the published standard 802.11-2007, or whether it appears in any of the pending amendments.  There are also two columns for each amdnement – one column stating what “is”, and the other column stating what “should be”.  The amendments columns are ordered in planned publication order and reflects the current official timeline established by the Task Group Chairs (when the planned order of publications changes then the Working Group Technical Editor or his designate will update the spreadsheet to reflect the new timeline; this is beyond the scope of this document). At the top of the column for what “is” appears the current draft number, e.g. D11.0. The entries in that column list every clause which appears in the draft. 
The entry for a clause that is being modified from the existing published standard will appear in the same row as that clause in the 802.11-2007 column. 
For example, consider clause 7.2.3.1 (the Beacon frame), which everyone seems to modify. In addition to the entry for the published standard 802.11-2007, there is an entry in that row for TGk, TGr, TGy, and others.

The entry for a new clause that is being inserted into the standard will appear in its own row, correctly ordered with the existing clauses.  

For example, with TGk adding a new clause to follow 5.2.6, the TGk editor assigned clause number 5.2.7, and added a new row to the spreadsheet after the row for the existing 802.11-2007 clause 5.2.6. Subsequent subclauses 5.2.7.1 through 5.2.7.11 appear on the following rows. TGy also adds a clause to follow 5.2.6; since TGy follows TGk in the timeline the TGy editor assigns clause number 5.2.8 and adds new rows to the spreadsheet below the row for 5.2.7.11; three rows are added for 5.2.8, 5.2.8.1, and 5.2.8.2.  Similarly the editor for TGn added a row for their clause inserted after 5.2.6 – their clause number assigned is 5.2.9.
Assume for the purposes of this example that a new D0.0 being generated for TGx is scheduled to be published between TGy and TGn, and adds a clause after 5.2.6. A pair of columns are added to the spreadsheet between the columns for TGy and TGn, and a row is inserted above TGn’s row for their 5.2.9. The number to assign for this clause in TGx is 5.2.9, which is the proper number based on the publication order, and TGn needs to shift their clause number to 5.2.10.  This is noted in the spreadsheet by entering a value of 5.2.10 in the “should be” column for TGn next to their existing entry for their clause 5.2.9, and highlighting the cell with 5.2.10 in yellow so that it is noticed later by the TGn editor.  Similarly any later task groups that are also adding clauses after 5.2.6 of the published standard will also need to be updated, and should be marked in the same way with their new proper number.
These two cases, of a new clause and an existing clause being modified, sometimes both occur simultaneously. Consider 7.3.2.27, which is a new clause being added by TGk, but modified by TGr and TGs.  The spreadsheet shows a new row added in the proper order for 7.3.2.37 by TGk, and further entries in that row for the later amendments that make modifications.

The spreadsheet pages for definitions, figures, and tables are similar to the page for clauses, and need no further explanation.

The spreadsheet page for MIB entries identifies certain entries in the MIB that need to be coordinated between amendments. It is important that the MIB be compilable after each amendment, so no gaps are allowed in the sequential number of certain entries, e.g. dot11StationConfirEntry values.  While the format is slightly different, the intent and use of the spreadsheet is the same. 

For example, dot11smt in the published standard contains entries for 1-13. TGk added one entry, numbered 14, TGr added one entry, numbered 15, etc. Later drafts are assigned the next values in sequence. Another good example of this is dot11StationConfigEntry, where many drafts add entries that all need to be coordinated.

The column for 802.11-2007, which normally contains only the entries that are present in the published standard, here shows new MIB tables, highlighted in yellow.
One other strange type of entry on the MIB page is for dot11SMTbase, where one of the conformance statements is marked as “current” and all previous ones are marked “obsolete”. The single row of the spreadsheet identified as “dot11SMTbase” contains entries “x->y”, where x (e.g. 6, for dot11SMTbase6) is being marked “obsolete” and y (e.g. 7, for dot11SMTbase7) is being marked “current”. 
4.11 Conditional text

One of the useful features provided by FrameMaker is called “Conditional Text”. This is text that can appear in the source file, but not appear in the printed output.  It is very useful for storing notes to the editor. 

In these procedures given in this document, three types of conditional text are used:

· Comments. These are short tags attached to changes that identify the source of the changes.  When they are displayed in the redline file, every place a changebar appears in the document there should be a comment tag.  During Working Group ballots the comments are shown in the redline version of the draft. During Sponsor Ballot the comments are shown in the audit version of the draft. All text of this type is removed before the next ballot.

· EditorInfo. These are notes from the editor to himself/herself. Examples are to-do items such as ANA requests. This tag is also useful for noting places where the text in the amendment depends on prior amendments, such as the order numbers for frames in subclause 7.2.3; inserting an note of type EditorInfo containing “11x” at that point enables simple searching for dependencies on the other amendment. During Working Group ballots the EditorInfo is shown in the redline version of the draft. During Sponsor Ballot the EditorInfo is never shown.

· RedlineInfo. These are notes that appear in the redline version of the draft, and are used to identify changes that can’t be shown by simple underlining and strikethrough.  An example is the addition of a column to a table, or splitting a paragraph into two separate paragraphs. During all ballots the RedlineInfo is shown in the redline version of the draft. All text of this type is removed before the next ballot.

In addition, FrameMaker uses two types of conditional text in its comparison documents, Inserted and Deleted.

To create the Conditional Text tags, click on Special->ConditionalText. Then click “Edit Condition Tag”. Change Tag from “ConditionName” to “EditorInfo”, set Style to “As Is”, and Color to “As Is”. Then click “Set”. Repeat this procedure for Tag “RedlineInfo”.  The tag “Comment” already exists in the template, Select it in the list and click “Edit Condition Tag”, change Style to “As Is”, and Color to “Magenta”. To mark text as conditional, select it and then press Ctrl-4, then downarrow until the bottom status row of the window displays the correct tag, then press Enter.

4.12 Editor’s notes

Editor’s notes can be used for two different purposes in an amendment: information for the voters, and information for the editor. In neither case will the text appear in the final published document.

There are several strange things about FrameMaker that continue to confuse the voters of 802.11 (especially those that are familiar with MSWord).  Two items in particular are the use of line numbers in the margin (and the fact that they don’t exactly line up with the text), and the way tables and figures float.

As a way to help educate the 802.11 voters, some drafts have included a page in the frontmatter called “Editorial Notes”. The following content has appeared, and found to be effective:

EDITORIAL NOTE—The default IEEE-SA style for tables is to “float”. This means that they be repositioned later, usually at the head of the next page, to avoid splitting the table and reduce the amount of blank space. The table can appear to move out of the subclause it is referenced first from, and can even split a paragraph. This is the intended IEEE-SA behavior, please do not report it as a defect in the draft.

EDITORIAL NOTE—Line numbering is only approximate. This is a limitation of the FrameMaker tool. Whitespace between paragraphs is part of the IEEE-SA style, as defined in their templates. The combination of these two facts leads to the appearance of blank lines in the draft between every paragraph. Please do not report this as an editorial defect as it is the unavoidable behavior.

The other purpose of an Editor’s note is to serve as a reminder to the Editor.  These are useful to mark places in the amendment where the text depends on prior amendments, and will need to change if those prior amendments change.  For example, in subclause 7.2.3.1, Beacon frame format, the order numbers that appear in Table 7-8 need to be sequential when the amendment is published. An Editorial Note below the table could note the final order number in 802.11-2007, the number used in 802.11k-D13.0, the number used in 802.11r-D9.0, the number used in 802.11y-D7.0, the number used in 802.11w-D5.0, etc. Searching for the string “11w” when a new draft of 11w is issued will then find all these dependencies.  Such an editorial note might appear as:

EDITORIAL NOTE – 802.11-2007 last entry is order 24; 802.11k-D10.0 added 25-32.

Editor’s notes are typed as normal text, then converted to style “Note” (Format->Paragraphs->Note). The text of the paragraph is then selected and click on Format->Paragraphs->Designer (or hit Ctrl-M), on the “Default Font” tab set the “Color” to “Red”, and then click “Apply”.

The latter type of editor’s notes are not useful to the voters, and should not appear in the “clean” version of the draft for balloting.  To suppress them, apply the Conditional Text tag “EditorInfo” (select the text of the paragraph, then press Ctrl-4, and press downarrow until the bottom line of the window shows “EditorInfo”, then press enter.

4.13 Change history

A table showing the change history of the document is often interesting, and may be useful to keep track of approved submissions that have already been applied to the draft.  This table should not appear in a “clean” draft for balloting, but can appear in the “redline” draft.

The easiest place to insert such a change history table is at the end of the frontmatter, after the Table of Contents.  The frontmatter template ends with “Contents” (which will be filled in later during the generation of a pdf output file). Set the cursor at the end of the word “Contents”, and press Enter twice, and then type “Change history”. Select the line “Change history” and click Format->Paragraphs->contheader.  The Change history will now appear on a new page. Set the cursor to the start of the line after the “Change history” title, and click Table->InsertTable. Select “IEEE format”, set Columns to 3, Body Rows to 10, Heading Rows to 1, and Footing Rows to 0. Then click “Insert”. The cursor will be at the table title; enter “Change history” for the table title. Place the cursor anywhere in the third column of the table and click Table->ResizeColumns. Select “To Width” and set the width to “216pt”
. Click “Resize”. Set the heading for the left column to “Date” and the heading for the center column to “Draft” and the heading for the right column to “Submission”.

To make the Change history table not appear in the “clean” version of the draft, it needs to be made Conditional Text.  Select the entire line “Change history” at the top of the page, and the little black square on the next line (the “handle” for the table). Press Ctrl-4 and downarrow until the bottom status row of the window shows “EditorInfo”, then press Enter.

5 Updating the draft

Changes are entered into the FrameMaker source files based on motions approved by the Task Group. 
This section is written without repeating much of the basics of working with FrameMaker, assuming that the reader has previously gone through the procedures given in 4 in generating the initial D0.0.  If this is not the case, you may want to read this section in conjunction with the similar sections of 4.

5.1 Draft numbering

The first step in this updating is to make a new copy of the source files, Dx.yy-frontmatter.fm and Dx.yy-body.fm.

Before the first ballot, drafts are always numbered D0.yy, where yy is a monotonically increasing value chosen by the editor (or task group).  For example, after the initial draft, D0.0, the editor creates D0.1, D0.2, D0.4, D0.7, D0.9, and D0.93.

Balloted drafts are always numbered Dx.0, where x denotes the xth ballot or recirculation.  First ballot is always D1.0; second ballot is always D2.0; third ballot is always D3.0, etc.

Drafts between ballots are numbered Dx.yy, where x is the most recent ballot, and yy is a monotonically increasing value chosen by the editor (or task group). For example, after a ballot of D2.0, the editor creates D2.2, then D2.5, D2.61, D2.65, D2.7, and D2.8.

5.2 Tracing the cause of changes

It is important that all changes made to the draft be traceable to a motion that was approved by the Task Group.  Questions often arise about why a certain change was made (often by someone not paying close attention as a motion is debated); the simplest way to deal with such questions is to have an indication in the draft that tells what caused the change.  The procedures in this document use conditional text with tag “Comment”, showing either a comment number (e.g. [#351]), or a submission (e.g. [0214r3]). This information is shown in a unique color in the redline version of the draft.

A more practical reason to keep the comment tags is for backing out changes. A Task Group often “changes its mind” about certain changes and approves an updated resolution to a prior comment. When this happens, the editor has to find all the changes made to the draft by the previous resolution and remove them. This is especially difficult when multiple comment resolutions made the same change, but only one is being revised. Searching for the tags makes this easier (note, it doesn’t make it easy).

5.3 Submissions and comment resolutions

5.3.1 Text

Procedures for doing normal editing of the text in the draft are not given here.  This document is long enough already.
The editor may at times be directed by motion or by comment resolution to make changes to the draft without detailed text changes being reviewed by the Task Group. The editor should keep an accurate record of each action taken from such direction, and bring to the attention of the Task Group Chair all concerns from non-specific directions, especially in the case a contentious issue is found, the issue “snowballs”, conflicting directions exist, critical timing, etc.

There are two aspects of making changes to the text that are non-obvious: use of the “Comment” Conditional Text tags, and use of Editor’s Notes to point out changes.

As explained in 5.2, marking the cause of text changes can be very useful in later editing of the draft. These tags should not appear in the “clean” version of the draft, and so are made using the FrameMaker Conditional Text capability, using the tag “Comment”.  The general form of a comment is a sequence of submission numbers (four-digit number, “r”, revision number) and comment numbers (“#”, spreadsheet row number), separated by commas, and enclosed in square brackets.
As an example, consider a change approved in the resolution to comment #46 to insert the text “non-AP” in front of “STA”. Point the cursor in front of the “S” of “STA”, and type “non-AP<spacebar>”. The editing part is done.  To tag the change, move the cursor back one character (next to “non-AP”) and enter “[#46]”. Select the text just entered (simplest way is to hold down the shift key and press the left arrow five times), then press Ctrl-4 and then Enter.  The tag is done.

Some changes made to the text in a draft can’t be shown with underline/strikethrough. An example is splitting a paragraph into two separate paragraphs. Another example is reformatting a list (e.g. changing a list from an ordered list to a dash list). Any change that can’t be shown with underline/strikethrough needs an Editor’s Note.  The Editor’s Note is entered as a separate paragraph under the change, and points out what was changed in the text. This Editor’s Note should not appear in the “clean” version of the draft, so it should be made into Conditional Text, with the tag “RedlineInfo”.  First, select the text of the Editor’s Note, and format it with style “Note” (Format->Paragraphs->Note).  Then with the text still selected, press Ctrl-M, and select the “Default Font” tab. Change the Color to “Red”, click the box marked “Changebar”, and press “Apply”.  With the text still selected, press Ctrl-4 and downarrow until the status line at the bottom of the FrameMaker window shows “RedlineInfo”, then press Enter.  The note is done.
5.3.2 Tables

Changing the content of cells in a table is exactly the same as changing text outside of the table. FrameMaker will catch such changes and adequately show them in a redline version of the draft.
Rows/columns are added to the table through the Table->AddRowsorColumns. Place the cursor adjacent to the place where a new row/column is needed, and click on Table->AddROwsorColumn. Select either rows or columns to add, tell it how many, and whether it is above/below/left/right of the cursor, and then click “Add”.  If adding columns, the new column as well as the existing columns will likely need to be re-sized to fit on the page. Procedures for re-sizing of columns are in 4.6.
Any change to a table other than changing the content of existing cells won’t be shown with underline/strikethrough in the “redline” draft. FrameMaker will instead show the previous table as deleted, and a new table inserted. So it needs an Editor’s Note to explain what was changed.  The Editor’s Note is entered as a separate paragraph under the table, and points out what was changed in the table. This Editor’s Note should not appear in the “clean” version of the draft, so it should be made into Conditional Text, with the tag “RedlineInfo”.  First, select the text of the Editor’s Note, and format it with style “Note” (Format->Paragraphs->Note).  Then with the text still selected, press Ctrl-M, and select the “Default Font” tab. Change the Color to “Red”, click the box marked “Changebar”, and press “Apply”.  With the text still selected, press Ctrl-4 and downarrow until the status line at the bottom of the FrameMaker window shows “RedlineInfo”, then press Enter.  The note is done.

If a table is deleted, but the text around it is unchanged (unlikely but possible), FrameMaker will not show this adequately in the “redline” version of the draft.  It will show the “handle” of the table in red, above the table in normal color, and “those in the know” recognize that means the entire table was deleted. An Editor’s Note is appropriate here, too.  If the text around the table is deleted along with the table, Framemaker will show the deleted text in red in the “redline” draft, and it should be clear enough to the voters that no additional note is required.

5.3.3 Figures

FrameMaker often shows figures as changed in the “redline” version of the draft, whether they were changed or not. This is unfortunate, but no solution is known (other than the manual one of editing the redline version after it is created).
Changes in figures should always be made in the original figure source file.  This is especially true if the figure is an imported Visio drawing; while possible to do minor editing within the FrameMaker file, it leads to chaos later.  After making the changes in the figure’s source file, the figure is imported into the body.fm file just as it was initially imported.  To see how it was imported before – right-click with the cursor pointing inside the figure, and select “Object Properties”. In the popup window, look at the “Facets” near the bottom – if it says “TIFF” then it was imported from a TIF file (as described in 4.5.2), and if it says “OLE2” then it was copy/pasted from the Visio source file (as described in 4.5.3).

The old figure is deleted by selecting the graphic frame (pointing the cursor at the figure and left-click), and then pressing “delete”. If the change made to the figure alters its size, then the full procedure given in 4.5.2/4.5.3 needs to be done to adjust the various frame positions and sizes.  If the figure size is unchanged, then simply importing/pasting the new figure should be sufficient. Note that if the figure was a Visio pasted into the body.fm file, it may need to be re-scaled as described in 4.5.3.
Any change to a figure won’t be shown with underline/strikethrough in the “redline” draft. FrameMaker will instead show the previous figure as deleted, and a new figure inserted. So it needs an Editor’s Note to explain what was changed.  The Editor’s Note is entered as a separate paragraph under the figure, and points out what was changed in the figure. This Editor’s Note should not appear in the “clean” version of the draft, so it should be made into Conditional Text, with the tag “RedlineInfo”.  First, select the text of the Editor’s Note, and format it with style “Note” (Format->Paragraphs->Note).  Then with the text still selected, press Ctrl-M, and select the “Default Font” tab. Change the Color to “Red”, click the box marked “Changebar”, and press “Apply”.  With the text still selected, press Ctrl-4 and downarrow until the status line at the bottom of the FrameMaker window shows “RedlineInfo”, then press Enter.  The note is done.

5.4 Editorial fixes

It is very tempting to think that every change in the draft that is not tagged with a submission or comment ID is an editorial fix; this is very dangerous thinking.  Far better to tag all the editorial fixes with a “[Ed]” and keep the rule that every changebar have a tag associated with it.  Then every change that is not tagged is a problem to be investigated – much safer.
It is also very useful to have a short paragraph at the beginning of the redline version that states:

EDITORIAL NOTE - This redline version compared D5.0 and D6.0 of the draft. Inserted text is shown as Inserted Text, deleted text is shown as Deleted Text, and Indications of comment numbers and submissions causing the changes are shown as [Comment/submission].

The words “Inserted Text” should be in the same color as the inserted text, “Deleted Text” should be strikethrough, and “[Comment/submission]” should be the same color as the comment tags. All the remaining text of the Editorial note should be red. This text should be conditional, with tag “RedlineInfo”

5.5 Interaction with other drafts

The numbering spreadsheet, described in 4.10, maintains a list of all interactions between pending drafts, and identifies both overlaps (where multiple drafts are modifying the same clause/figure/table) and dependencies (where multiple drafts are inserting at the same point in the published standard). With each new draft, the editor needs to make the corresponding updates to the numbering spreadsheet.

5.5.1 Updating the numbering spreadsheet

Any new clauses/figures/tables being added to the draft need to be added to the numbering spreadsheet. The procedure for inserting new entries is identical to the procedure used for the initial D0.0, as described in 4.10.

If a clause/figure/table is being deleted from the draft, then the corresponding row in the numbering spreadsheet should be deleted. This may affect the numbering of items in later drafts, and the entries for the later drafts need to be updated in the same way as for additions (see 4.10).

If the addition or deletion is one clause/figure/table in a rage of clauses/figures/tables that were inserted by this draft (e.g. if the figure previously identified as 7-95b is being deleted from TGk, and figures 7-95a through 7-95h were are all previously identified as being added by TGk), and later drafts are showing a dependency on a figure in this group (e.g. 7-95c shows in the columns for TGr and TGn), then the entries for the later drafts need to be updated.  In the example case, it means the “should be” columns for TGr and TGn should contain 7-95b (the new designation of that figure), highlighted in yellow.

If the clause/figure/table being deleted is shown in the spreadsheet as the subject of a further modification by a later draft, an email exchange with the editor of the affected draft is appropriate.  There is no good way to show this type of problem in the spreadsheet.

5.5.2 Text

Through use of the numbering spreadsheet page labelled “clauses”, the clauses affected by your draft that are also being modified by earlier drafts are apparent.  For every entry in the column for your draft, check the columns to the left – any entry (other than the one for 802.11-2007) indicates a potential need for “text tracking”.
It is important to keep accurate any text that your draft is quoting. Any changes to the baseline text (the published 802.11-2007, as modified by all previous amendments) need to be incorporated into your draft. These changes should be identified in the “redline” version of your draft with a comment tag indicating the prior amendment that made the change, e.g. “[11k]”.

Similarly any dependencies for tables and figures can be detected from the numbering spreadsheet, and the base table/figure updated appropriately. Changes to figures, and some types of changes to tables, do not show very well in the redline version of the draft, and need to be identified by an Editor’s Note below the table/figure.

5.5.3 Numbering

Changes needed to clause/figure/table numbering are all identified by the numbering spreadsheet.  Look in the column “should be” for your draft for any yellow entries.  In addition to adjusting the “numbering” tab in the paragraph properties for the heading or caption, it may be necessary to update the editing instructions to properly identify the place to insert/change the base document.

Once fixed, update the cells of the “is” column, delete the yellow cells, and upload a new spreadsheet.

5.6 Special case – updating the frontmatter during Sponsor Ballot

Since the redline version is the balloted draft during Sponsor Ballot, we need to include a frontmatter showing the changes.  Unfortunately FrameMaker is unable to compare the current frontmatter.fm against the previous frontmatter.fm and generate a redline. 

The document comparison utility of FrameMaker generates a file with two conditional text tags defined, “Inserted” and “Deleted”. Text that has been added to the older file is tagged as “Inserted”, and text that has been removed is tagged as “Deleted”. This process is done manually for frontmatter. 

To create the Conditional Text tags, click on Special->ConditionalText. Then click “Edit Condition Tag”. Change Tag from “ConditionName” to “Inserted”, set Style to “As Is”, and Color to “Forest Green”. Then click “Set”. Then click “Edit Condition Tag”. Change Tag from “ConditionName” to “Deleted”, set Style to “Strikethrough”, and Color to “Red”. Then click “Set”.
Instead of simply making the changes to the frontmatter.fm source file, you need to tag any new text as “Inserted”, and tag any text to be deleted as “Deleted”. For new text, select the text, press Ctrl-4, and downarrow until the status row in the bottom of the window says “Inserted”, then press Enter.  Similarly for deleted text to tag it as “Deleted”.

Fortunately, by the time a draft reaches Sponsor Ballot there are few changes made to the frontmatter. The only likely changes are to the draft number and date on the first page, and possibly in the box at the top of page iii.

6 Generating a draft for WG Ballot

This section gives the step-by-step procedures for generating the pdf files of a draft.  The first two sections, for the “clean” and “redline” versions, put their output in temporary files for the editor. The actual file names for the published versions are specified by 802.11, and the rules are given in 6.3. An overview of the other rules that affect the editor in the preparation of drafts are given in 6.4.
6.1 Procedure for generating the “clean” pdf file

The step-by-step procedure in this section assumes the files are named Dx.yy-frontmatter.fm and Dx.yy-body.fm, and the output file will be Dx.yy.pdf

1) In Dx.yy-frontmatter.fm, fix draft number and date in top line and first line of title, and possibly in the box on top of page iii
2) In Dx.yy-frontmatter.fm, add any new presenters to the list of contributors
3) In Dx.yy-frontmatter.fm, update change history table. Need to turn on display of EditorInfo text (Special->ConditionalText->Show/Hide, select "EditorInfo", press "<--", Set, Wait. Then exit the dialog box)

4) In Dx.yy-body.fm, Master pages, left and right pages, 2 places to put draft number (keep overrides)

5) In Dx.yy-body.fm, first line of title has draft number

6) Turn off display of comment text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

7) Run spell checker --  Edit->Spelling Checker

8) Save both Dx.yy-body.fm and Dx.yy-frontmatter.fm files

9) Turn off display of comment text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

10) Delete any blank pages (often some have just appeared) at end of frontmatter and body.

11) Load up file D0.0-numbers.fm (this is a 12-line file, “CONTENTS”, 3 blank lines, “FIGURES”, 3 blank lines, “TABLES”, 3 blank lines)

12) New->Book, say “no” to adding current file.

13) Add->Files, select Dx.yy-frontmatter.fm, then “Add”

14) Add->Files, select Dx.yy-body.fm, then “Add”

15) Select Dx.yy-body in the Book window

16) Add->Table of Contents. Select tags: AH1, AH2, AH3, AH4, AI, H1, H2, H3, H4; add “before Dx.yy-body.fm”, then “Add”. Ignore the “Book error report”

17) Go to the just-created window with the Table of Contents information, select it all, copy to clipboard

18) Go back to Dx.yy-frontmatter.fm, and Paste TOC into the file

19) Go back to D0.0-number.fm, and Paste TOC into the file (at middle line under “CONTENTS”)

20) Select Dx.yy-body in the Book window

21) Add->List->Figures. Select tags: FigCaption, FigTitle; add “before Dx.yy-body.fm”, then “Add”. Ignore the “Book error report”

22) Go to the just-created window with the List of Figures, select it all, copy to clipboard

23) Go back to the D0.0-numbers.fm, and Paste LOF into the file (at middle line under “FIGURES”)

24) Select Dx.yy-body in the Book window

25) Add->List->Tables. Select tags: ATableTitle, TableCaption, TableTitle; add “before Dx.yy-body.fm”, then “Add”. Ignore the “Book error report”

26) Go to the just-created window with the List of Tables, select it all, copy to clipboard

27) Go back to the D0.0-numbers.fm, and Paste LOT into the file (at middle line under “TABLES”)

28) Save the D0.0-numbers.fm as Dx.yy-numbers.fm

29) Save the Dx.yy-frontmatter.fm file

30) In the book window, select the TOC file, Edit->DeleteFileFromBook

31) In the book window, select the LOF file, Edit->DeleteFileFromBook

32) In the book window, select the LOT file, Edit->DeleteFileFromBook

33) File->PrintBook, printer=”Adobe PDF”, GenerateAcrobatData=yes, PDF Setup should have (on the “Bookmarks” tab) “9>AH1, 17>AH2, 18>AH3, 18>AH4, 19>AH5, 8>AI, 8>AN, 8>Annexes, 8>AT, 9>H1, 12>H2, 14>H3, 15>H4, 16>H5”, File=Dx.yy.ps, Print. Ignore the errors about incompatible colors.

34) Double-click on the Dx.yy.ps file; Acrobat Distiller will generate Dx.yy.pdf

35) (Still in the Book window) File->CloseBook (don’t bother to save it)

36) File->Close the *TOC.fm files, *LOF.fm files, and *LOT.fm files; don’t bother saving them

6.2 Procedure for generating the “redline” pdf file

The requirements for “redline” drafts are given in 07/0788r0. They are:

· Use black&white underline text for inserted Amendment text

· Use black&white strikethrough text for deleted Amendment text

· Colored underline for inserted changed text

· Colored strikethrough text for deleted changed text

· Vertical lines in margin near all changed text.

The “redline” shall also include an editor’s note, marked with vertical bar in the margin, indicating 

· Meaning of the formats above

· Previously draft version number to which the changed text is referencing

· A statement of any changes that cannot be shown by text change marks, explaining what changed.

FrameMaker is capable of making a comparison document, which is the starting point for a redline version of the draft. However, it is not capable of making a good comparison document. For a Working Group ballot, the “redline” file is informative only, and not worth lots of effort to make it compact. One problem is that FrameMaker can’t seem to do a comparison of the frontmatter.fm file to the previous frontmatter.fm file; therefore don’t bother with a redline comparison of the frontmatter.

The step-by-step procedure in this section assumes the files are named Dx.yy-frontmatter.fm and Dx.yy-body.fm, and the output file will be Dx.yy-redline.pdf. The previous version (the basis for comparison) is in the file named Dx.0-body-clean.fm.

1) Load up previous Dx.0-body-clean.fm, and Dx.yy-body.fm
2) In the Dx.0-body-clean.fm window, turn off display of conditional text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

3) In the Dx.yy-body.fm window, turn off display of conditional text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

4) In the Dx.yy-body.fm window, File->Utilities->CompareDocuments. Select Dx.0-body-clean.fm as original. Compare.  This takes a little while (typ 5-10 min). It generates two files, Dx.yy-bodyCMP.fm and Summary.fm.
5) In the Dx.yy-bodyCMP.fm window, Special->ConditionalText, then Show/Hide, select “Comment”, <--, select "RedlineInfo", <--, select "EditorInfo", <--, Set.

6) (Still on Conditional Text dialog box), select “Inserted” then Edit, change color to “Forest Green”, then “Set”, then exit the dialog box.

7) Various things need to be done to make the redline file unsuitable for generating comments. A) on the Master Pages, delete the text box on the left margin with line numbers. B) Add “NOT FOR BALLOTING” to header (both sides) and footer (under page number) (Need to turn off changebar character style before doing this, Format->Character->Deisgner, uncheck Changebar). C) Make page numbers roman numerals Format->Document->Numbering, Page, Format Roman(XIV) [or Alphabetic(N) works too].

8) File->SaveAs, name it Dx.yy-redline-body.fm
9) Load up previous Dx.0-numbers.fm file

10) Select Dx.yy-numbers.fm window; File->Utilities->CompareDocuments; Select Dx.0-numbers.fm as original; Compare. Manually adjust output as necessary to make it show the real changes.

11) Save the Dx.yy-numbersCMP.fm as Dx.yy-redline-numbers.fm

12) Select Dx.yy-redline-numbers.fm window, Select all text, copy to clipboard

13) Select Dx.yy-frontmatter.fm window, Special->ConditionalText, then Show/Hide, select “Comment”, <--, select "EditorInfo", <--, Set.

14) Insert at end "Numbering Changes", make that new text style "contheader", paste clipboard after it

15) Special->ConditionalText, select “Inserted” then Edit, change color to “Forest Green”, then “Set”, then exit the dialog box.

16) Adjust the draft number in top line, and in first line of title, to show the change from previous draft. Select current value, CTRL+4, up/dn to select "Inserted", then Enter. Insert previous value, select it, CTRL+4, up/dn to select "Deleted", then Enter.
17) Adjust the date in top line to show the change from previous draft. Same procedure as previous step.

18) Change the "EditorInfo" note on first page to indicate correct old/new draft numbers.

19) Change the data in the new rows of the "Change History" table to conditional tag "Inserted"

20) Save the Dx.yy-frontmatter.fm as Dx.yy-redline-frontmatter.fm

21) New->Book, say “no” to adding current file.

22) Add->Files, select Dx.yy-redline-frontmatter.fm, then “Add”

23) Add->Files, select Dx.yy-redline-body.fm, then “Add”

24) Re-generate the Table of Contents, to get the page numbers right for the redline version of the draft. Add->Table of Contents. Select tags: AH1, AH2, AI, H1, H2, H3, H4; add “before Dx.yy-redline-body.fm”, then “Add”. Ignore the “Book error report”. Go to the just-created window with the Table of Contents information, select it all, copy to clipboard. Go back to Dx.yy-redline-frontmatter.fm, and Paste TOC into the file. In the book window, select the TOC file, Edit->DeleteFilefromBook.

25) File->PrintBook, printer=“Adobe PDF”, GenerateAcrobatData=yes, PDF Setup should have (on the “Bookmarks” tab) “9>AH1, 17>AH2, 18>AH3, 18>AH4, 19>AH5, 8>AI, 8>AN, 8>Annexes, 8>AT, 9>H1, 12>H2, 14>H3, 15>H4, 16>H5”, File=Dx.yy-redline.ps, Print. Ignore the errors about incompatible colors.

26) Double-click on the Dx.yy-redline.ps file; Acrobat Distiller will generate Dx.yy-redline.pdf

27) Close the Dx.0.fm file (FrameMaker claim that it changed is wrong, don’t save it)

28) Load Dx.yy-body.fm and Dx.yy-frontmatter.fm

29) Delete the comment tags in the frontmatter. In the Dx.yy-frontmatter.fm window, Special->ConditionalText, select “Comments”, Edit, then Delete. Select “Delete the text”, then OK.

30) Delete the Deleted text. (Still on ConditionalText dialog box), select "Deleted", Edit, then Delete. Select "Delete the text", then OK

31) Keep the Inserted text (Still on ConditionalText dialog box), select "Inserted", Edit, then Delete. Select "Make the text unconditional", then OK

32) (Still on ConditionalText dialog box), select Edit, make name “Comments”, Style “As is”, color “Magenta”, then Set; select Edit, make name "Inserted", Style "As Is", Color "Forest Green", Set; select Edit, make name "Deleted", Style "Strikethrough", Color "Red", Set. then exit the dialog box.

33) File->SaveAs, name it Dx.yy-frontmatter-clean.fm (This is the file to use for future updates after the letter ballot completes).

34) Delete the comment tags in the body. In the Dx.yy-body.fm window, Special->ConditionalText, select “Comments”, Edit, then Delete. Select “Delete the text”, then OK.

35) (Still on ConditionalText dialog box), select Edit, make name “Comments”, Style “As is”, color “Magenta”, then Set, then exit the dialog box.

36) Search (CTRL+F) for "Conditional Text" (change the "Text" to "Conditional Text" to the left of the normal place to enter the search string, and then on the popup window select "RedlineInfo", "<--" (twice), Set). Delete any that are present as documentation of changes that can't be shown by the normal strikethrough/underlining

37) File->SaveAs, name it Dx.yy-body-clean.fm (This is the file to use for future updates after the letter ballot completes).

38) Make a .zip archive of the entire directory, containing all files since last ballot. Send it to TG chair for his records.

6.3 Draft naming

Draft names are important, since they appear in various web links, documents, and scripts. Therefore there are very strict rules about how the drafts are named.
A clean draft for IEEE 802.11 Working Group posting must exactly be named: 

Draft(space)P802.11(a)(underscore)Dx.yz.pdf 
where:


	Symbol
	Replace with

	(space) 
	A single space

	(underscore) 
	A single underscore symbol

	(a) 
	For Amendments to Recommendations: The single or double letter designator of task group in lower case. 

For Revisions to Recommendation: Use REVmx, where mx is the current maintenance task group in lower case.

For Recommend Practice or standalone recommendation: The number of document. 

	x 
	The major revision number. The major revision number must increment by one from previous ballot draft.

	y
	The minor revision number. The minor revision number must be zero for all ballot drafts.

	z
	Second minor revision number (if any) or leave blank. Must be null for all ballot drafts.


	Wrong Example
	Corrected Example

	P802.11p D3.0.pdf
	Draft P802.11p_D3.0.pdf

	Draft 802.11y D5.0.pdf
	Draft P802.11y_D5.0.pdf

	Draft_P802.11v_D1.02.pdf
	Draft P802.11v_D1.02.pdf

Note that this cannot be a ballot draft. It must end in .0.

	Draft P802.11n D2.07.pdf
	Draft P802.11n_D2.07.pdf

Note that this cannot be a ballot draft. It must end in .0.

	Draft_P802.11s_D1.06.pdf
	Draft P802.11s_D1.06.pdf
Note that this cannot be a ballot draft. It must end in .0. 

	Draft P802.11.2-D0.13.pdf
	Draft P802.11.2_D0.13.pdf

Note that this cannot be a ballot draft. It must end in .0.

Note that this is a recommended practice or standalone document. 

	P802.11Mb D0.15.pdf
	Draft P802.11-REVmb_D0.15.pdf

Note that this is a revision.
Note that this cannot be a ballot draft. It must end in .0.


	Wrong Example
	Corrected Example

	P802.11p D3.0.pdf
	Draft P802.11p_D3.0.pdf

	Draft 802.11y D5.0.pdf
	Draft P802.11y_D5.0.pdf

	Draft_P802.11v_D1.02.pdf
	Draft P802.11v_D1.02.pdf

Note that this cannot be a ballot draft. It must end in .0.

	Draft P802.11n D2.07.pdf
	Draft P802.11n_D2.07.pdf

Note that this cannot be a ballot draft. It must end in .0.

	Draft_P802.11s_D1.06.pdf
	Draft P802.11s_D1.06.pdf
Note that this cannot be a ballot draft. It must end in .0. 

	Draft P802.11.2-D0.13.pdf
	Draft P802.11.2_D0.13.pdf

Note that this cannot be a ballot draft. It must end in .0.

Note that this is a recommended practice or standalone document. 

	P802.11Mb D0.15.pdf
	Draft P802.11-REVmb_D0.15.pdf

Note that this is a revision.
Note that this cannot be a ballot draft. It must end in .0.


Redline drafts are named following the conventions of our regular documentation and require Document Control Numbers (DCNs) to be obtained from the document server by the editor. The difference between these documents and regular documentation is that these documents are to be placed in the private members area of the web site and NOT on the documentation server. A Power Point file is generated by the editor with the same document number and placed on the document server. This document shall state that this document is a redlined version of a Draft and can only be found in the members only area of the IEEE 802.11 web site.

The file name for the redlined document shall be as follows: 

11-dd-cccc-rr-gggg(space)Redlined(space)Draft(space)P802.11(a)(underscore)Dx.yz.pdf

-OR

11-dd-cccc-rr-gggg(space)Redlined(space)Draft(space)P802.11(a)(underscore)Dx.yz (space)Compared(space)To(space) Draft(space)P802.11(a)(underscore)Dk.mn.pdf

where:
	Symbol
	Replace with

	(space) 
	As defined for Clean Draft previously.

	(underscore) 
	

	(a) 
	

	x 
	

	y
	

	z
	

	dd
	As defined and issued by the documentation system.

	cccc
	

	rr
	

	gggg
	

	k
	The major revision number of the older version for the redlined draft.  The comparison shall be omitted if the older version is D(x-1).0.

	m
	The minor revision number of the older version for the redlined draft.  The comparison shall be omitted if the older version is D(x-1).0.

	n
	Second minor revision number (if any) of the older version for the redlined draft or leave blank. . The comparison shall be omitted if the older version is D(x-1).0.


It is necessary to additional information at the end of the filename if non-standard redline formats are used, e.g., a redlined draft that shows only change bars, a redlined draft that shows only insertions. In such cases, it is strongly encouraged that the standard format be followed with non-standard formats provided as supplemental information.

	Wrong Example
	Corrected Example

	11-dd-cccc-rr-gggg P802.11p D3.0 Redline.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11p_D3.0.pdf

	11-dd-cccc-rr-gggg Redlined Draft P802.11y_D5.0 Compared to Draft P802.11y_D4.0.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11y_D5.0.pdf

	11-dd-cccc-rr-gggg Redlined-Draft -P802.11v-D1.02-To-D1.01.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11v_D1.02 Compared To Draft P802.11v_D1.01.pdf

	11-dd-cccc-rr-gggg Redlined-Draft-Between-P802.11n_D2.0-and-P802.11n_D1.0
	11-dd-cccc-rr-gggg Redlined Draft P802.11n_D2.0.pdf

	11-dd-cccc-rr-gggg Redline Draft_P802.11s_D1.06.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11s_D1.06 Compared To Draft P802.11s_D1.03.pdf

	11-dd-cccc-rr-gggg Redlined Draft P802.11.2-D0.13 vs. P802.11.2-D0.1.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11.2_D0.13 Compared to Draft P802.11.2_D0.1.pdf

	11-dd-cccc-rr-gggg Redlined Draft  P802.11Mb D0.15 Against D0.14.pdf
	11-dd-cccc-rr-gggg Redlined Draft P802.11Mb_D0.15 Compared To P802.11Mb_D0.14.pdf


6.4 Rules, Rules, Rules, and Timing

The 802.11 Policies and Procedures describe the rules for drafts in 2.9.2. They are totally inscrutable.  I defy anyone to read that clause and understand what the rules really are.  Perhaps it is intentionally written that way, leaving much to the interpretation of the WG Chair to decide.  But unfortunately that makes the rules somehat fluid, and “past performance is no guarantee of future results.”

Clause 2.9.2 states the rules as follows:

Before a draft is submitted to WG letter ballot, it shall meet all the following requirements:

1. The TG must approve the draft by vote with at least 75% concensus, indicating the TG has conducted a technical review of the draft, and believes the draft is technically complete, and ready for WG approval e.g. no place holders or notes for future action, editing, or clarifications.

2. It must be made available per subclause 2.5.

3. If any changes need to be made to the draft after posting, these changes, whether technical or editorial, shall be approved prior to the vote for approval to go to WG letter ballot. The editor will be instructed to incorporate these changes whether technical or editorial into the draft prior to the release of the draft to letter ballot.

4. Any voting member can bring a motion requesting that, after the editor has completed the draft, the editor’s work be approved by a fifteen-day confirmation electronic ballot. This will be a non-technical motion requiring simple majority.

5. The availability of the draft must be announced on the WG email reflector during or prior to the WG session or regularly scheduled interim session.

6. The draft must be formatted according to subclause 2.9.3.

7. The draft must be approved by a technical motion for submittal to WG letter ballot.  This approval shall be made at the 802.11™ WG closing plenary or via a fifteen-day electronic ballot.

Subclause 2.9.3, mentioned in rule #6 above, Formatting requirements for draft standard and amendments:

The draft must be provided in the current IEEE® electronic format (see refs. [rules1], [rules2], [rules3]). At a minimum this shall be completed prior to the Sponsor ballot however it is preferable that the draft be maintained in this format for its entire life.

Areas affecting existing clauses of IEEE® 802.11 shall be shown in the draft in underscore and strikeout against the current standard. Note that the amended draft standard may not be the same as the published standard due to approved but unpublished supplements.

Subclause 2.5, mentioned in rule #2 above, contains lots of requirements about submission formats. Very little of subclause 2.5 pertains to requirements for drafts. Perhaps it is a “typo” and meant to say subclause 2.6. The parts of subclause 2.5 that refer to drafts are:

In 2.5.2:

Draft standards and amendments shall be submitted to IEEE® in a format acceptable by the IEEE® standards department.  Draft standards and amendments shall be made available to the WG in Adobe Acrobat format.

In 2.5.3:

The layout of draft standards shall be according to the IEEE® style manual.

Further, subclause 2.6 states:

Motions may be made at appropriate times during the meetings.  However, all technical changes to a draft shall be in a submission that has been accepted by document control according to document formats specified in section 2.5 and has been made available electronically for a period of not less than four active WG session hours.

It is clear from rule #1 above that the initial draft needs to be approved by the Task Group as being “technically complete, and ready for WG approval e.g. no place holders or notes for future action, editing, or clarifications.”  It is not clear whether all of the pdf files generated by the editor prior to this motion are “drafts” or “submissions”.  One interpretation is that the first “draft” only comes into existance when the Task Group has approved it as “technically complete” – in this case all prior D0.xx are submissions, consist of technical changes that will change the draft (changing it from null to non-null), and therefore need to be available for four hours of WG session time before the motion.  The other interpretation is that all of the D0.xx are drafts, and only the other submissions are subject to the four-hour rule. No ruling has ever been made on this point; in its absence, assume the four-hour rule applies to the pdf file that will be the subject of the motion for technical completeness.
If the Task Group instructs the editor to generate a draft Dx.0 (and thus the motion brought to the Working Group simply asks for a letter ballot on Dx.0), it is unclear whether the Dx.0 needs to be available for four hours prior to the motion in the WG plenary.  It is generally believed that it does.

There is ambiguity about whether the rules are different for recirculation letter ballots. Rule #3 appears to cover the comment resolution spreadsheet, and the changes that need to be made to a draft before a recirculation ballot.  The comment resolution spreadsheet contains “changes [that] need to be made to the draft after posting.”  The “draft” here may refer to the previous balloted draft, and the “changes, whether technical or editorial” are the comment resolutions.  The comment resolution spreadsheet is approved by the Task Group, and a TG motion instructs the editor to incorporate those changes into the “draft” (i.e. the previous balloted draft) prior to the release of the “draft” (i.e. the new draft to be the subject of the letter ballot).  While this seems to be the current interpretation, other interpretations are possible.
Rule #4 can require that the Dx.0 be made available for inspection prior to the letter ballot.  The first sentence refers to two separate motions (motion requesting the editor’s work be approved, and the motion to approve the editor’s work). The word “this” in the second sentence could be interpreted to mean either of the two motions.  The result of one interpretation is that a single voting member can cause a 15-day confirmation ballot; the result of the other interpretation is that the 15-day confirmation ballot only happens when a majority of the voting members at the plenary session request it.

Rule #5 requires that the availability of the draft be announced during the WG session.  This can be interpreted to mean that the draft needs to be available during the WG session, or it could be interpreted to mean that the lack of the draft’s availability needs to be announced.  Currently this rule is generally ignored.

The current interpretation of these rules, and the affects on the technical editor, are:

· The last intermediate draft prior to initial WG letter ballot needs to be available for four hours prior to the vote in the Task Group that it is technically complete.  Therefore the technical editor may need to burn some midnight oil to make this happen.
· A draft for recirculation does not need to be available to the WG before approval. This can be generated at the editor’s convenience after a WG session has ended (keeping in mind that it would be nice if the resulting ballot finishes before the start of the next session, so don’t push this too far).

7 Mandatory Editorial Coordination
Before a draft can proceed to Sponsor Ballot it needs to be checked by the IEEE Publications Department. This is called “Mandatory Editorial Coordination”, or MEC, and takes up to 6 weeks.

The procedure is explained at http://standards.ieee.org/resources/development/balloting/pre-ballot.html.

In addition to information that identifies the Task Group, and the contact information for the editor, the web form at the above URL provides for uploading a file containing the draft.  This file should be zipped to reduce upload time.  The zip file should contain the latest draft (clean version), along with any permission letters for any copyrighted content that appears in the draft.
The report on pre-ballot Mandatory Editorial Coordination contains three sections:

Section I: items/issues that shall be resolved before the ballot begins

Section II: Items/isues that shall be resolved before the final recirculation

Section III: Recommended changes

Section I may contain items such as missing/mis-dated copyright notices, wrong IEEE contact information, missing disclaimer statements, or other such.  These they consider so important that a draft cannot be released to Sponsor Ballot unless they are fixed.

Section II contains requests to verify trademark status of anything in the draft, and to check for any registration of objects that are needed from this draft (note – 802.11 ANA registrations don’t count here).

Section III contains comments that should be considered along with other comments from voters in a ballot. 

The optimum situation is for the MEC to complete just as a (possibly final) Working Group recirculation ballot completes. If there happen to be no new comments from the WG voters and no Section I comments from the MEC, then the draft proceeds on to Sponsor Ballot.  Otherwise, the MEC issues are added to the comment spreadsheet and draft updated and recirculated again in the Working Group.  Note that (IEEE-SA/LMSC/802.11?) requires that the draft sent for initial Sponsor Ballot be identical to the draft that passed the final Working Group ballot, so the Section I issues can’t be resolved without another Working Group recirculation.
8 Generating a draft for Sponsor Ballot

This section gives the step-by-step procedures for generation of the pdf file that will be used in Sponsor Ballot voting. It is slightly different than the pdf files generated for Working Group ballots, and seems less confusing to repeat the whole procedure rather than to attempt to identify and explain the differences.
8.1 Procedure for generating the pdf file

Sponsor Ballots only require a single pdf file, showing the changes from the previous balloted draft.  Since the voters are looking closely at the redline file, and anything strange in the redline file will likely lead to a negative vote and comment, it is worthwhile spending some time making it look as accurate as possible.  This requires some manual intervention after FrameMaker has generated the comparison.

In the following step-by-step procedures, the previous draft is referred to as Dx.0-body-clean.fm, and the files for the new draft are referred to as Dx.yy-frontmatter.fm and Dx.yy-body.fm.  The frontmatter file is assumed to already have the Inserted/Deleted conditional text, through editing as was described in 5.6.

The output of this procedure is two pdf files, Dx.yy-redline.pdf and Dx.yy-audit.pdf. The former is used for the next Sponsor Ballot recirculation, and the latter is provided to the Chair as documentation of the changes made.

1) Load up previous Dx.0-body-clean.fm, new Dx.yy-body.fm, and new Dx.yy-frontmatter.fm files.
2) In the Dx.0-body-clean.fm window, turn off display of conditional text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

3) In the Dx.yy-body.fm window, turn off display of conditional text (Special->Conditional Text->Show/Hide, select “Comment”, press “-->”, select "EditorInfo", press "-->", (Same for any and all others, too). Set. Wait. Then exit the dialog box.)

4) In the Dx.yy-body.fm window, File->Utilities->CompareDocuments. Select Dx.0-body-clean.fm as original. Compare.  This takes a little while (typ 5-10 min). It generates two files, Dx.yy-bodyCMP.fm and Summary.fm.
5) Special->ConditionalText, then Show/Hide, select “Comment”, <--, select "RedlineInfo", <--, select "EditorInfo", <--, Set.

6) (Still on Conditional Text dialog box), select “Inserted” then Edit, change color to “Forest Green”, then “Set”, then exit the dialog box.

7) A LOT of manual cleanup is needed of the CMP file generated by FrameMaker.  Unchanged figures often show as deleted and re-inserted (delete the one of type "Deleted" to keep the cross reference tags pointing right). FrameMaker often guesses wrong about text changes, and shows something very complex when the changes was actually very simple. Leaving the complexity showing in the changebar file leads to Sponsor Ballot recirculation comments.  After cleanup, set "Inserted" to show and "Deleted" to hide, and compare against the clean Dx.y-body.fm -- should be no changes. Next set "Inserted" to hide, and "Deleted" to show, and compare against the previous draft -- should be no text changes (but likely lots and lots of figure and cross reference changes, which can be safely ignored).

8) File->SaveAs, name it Dx.yy-redline-body.fm
9) Select Dx.yy-frontmatter.fm window, Special->ConditionalText, then Show/Hide, select “Comment”, <--, select "EditorInfo", <--, Set.

10) Special->ConditionalText, select “Inserted” then Edit, change color to “Forest Green”, then “Set”, then exit the dialog box.

11) Adjust the draft number in top line, and in first line of title, to show the change from previous draft. Select current value, CTRL+4, up/dn to select "Inserted", then Enter. Insert previous value, select it, CTRL+4, up/dn to select "Deleted", then Enter.
12) Adjust the date in top line to show the change from previous draft. Same procedure as previous step.

13) Change the "EditorInfo" note on first page to indicate correct old/new draft numbers.

14) Delete the “Change History” if it hasn’t been deleted yet.

15) Save the Dx.yy-frontmatter.fm as Dx.yy-redline-frontmatter.fm

16) New->Book, say “no” to adding current file.

17) Add->Files, select Dx.yy-redline-frontmatter.fm, then “Add”

18) Add->Files, select Dx.yy-redline-body.fm, then “Add”

19) File->PrintBook, printer=”Adobe PDF”, GenerateAcrobatData=yes, PDF Setup should have (on the “Bookmarks” tab) “9>AH1, 17>AH2, 18>AH3, 18>AH4, 19>AH5, 8>AI, 8>AN, 8>Annexes, 8>AT, 9>H1, 12>H2, 14>H3, 15>H4, 16>H5”, File=Dx.yy-audit.ps, Print. Ignore the errors about incompatible colors. The main purpose of this file is to show the comment tags as an audit trail. Note that this file will not have a Table of Contents, but since it’s for our own use that doesn’t matter.
20) Double-click on the Dx.yy-audit.ps file; Acrobat Distiller will generate Dx.yy-audit.pdf

21) In the Dx.yy-redline-body.fm window, Special->ConditionalText, Show/Hide, select "Comments", -->, select "EditorInfo", -->, Set. Delete any blank pages at end of file.

22) In the Dx.yy-redline-frontmatter.fm window, Special->ConditionalText, Show/Hide, select "Comments", -->, select "EditorInfo", -->, Set. Delete any blank pages at end of file

23) Generate the Table of Contents. (In the Book window) Add->Table of Contents. Select tags: AH1, AH2, AI, H1, H2, H3, H4; add “before Dx.yy-redline-body.fm”, then “Add”. Ignore the “Book error report”. Go to the just-created window with the Table of Contents information, select it all, copy to clipboard. Go back to Dx.yy-redline-frontmatter.fm, and Paste TOC into the file. In the book window, select the TOC file, Edit->DeleteFilefromBook.

24) File->PrintBook, printer=”Adobe PDF”, GenerateAcrobatData=yes, PDF Setup should have (on the “Bookmarks” tab) “9>AH1, 17>AH2, 18>AH3, 18>AH4, 19>AH5, 8>AI, 8>AN, 8>Annexes, 8>AT, 9>H1, 12>H2, 14>H3, 15>H4, 16>H5”, File=Dx.yy-redline.ps, Print. Ignore the errors about incompatible colors.

25) Save the Dx.yy-redline-body.fm and Dx.yy-redline-frontmatter.fm files again (since printing changes the file somehow).

26) Close the Dx.0.fm file (FrameMaker claim that it changed is wrong, don’t save it)

27) Double-click on the Dx.yy-redline.ps file; Acrobat Distiller will generate Dx.yy-redline.pdf

28) Load Dx.yy-body.fm and Dx.yy-frontmatter.fm

29) Delete the comment tags in the frontmatter. In the Dx.yy-frontmatter.fm window, Special->ConditionalText, select “Comments”, Edit, then Delete. Select “Delete the text”, then OK.

30) Delete the Deleted text. (Still on ConditionalText dialog box), select "Deleted", Edit, then Delete. Select "Delete the text", then OK

31) Keep the Inserted text (Still on ConditionalText dialog box), select "Inserted", Edit, then Delete. Select "Make the text unconditional", then OK

32) (Still on ConditionalText dialog box), select Edit, make name “Comments”, Style “As is”, color “Magenta”, then Set; select Edit, make name "Inserted", Style "As Is", Color "Forest Green", Set; select Edit, make name "Deleted", Style "Strikethrough", Color "Red", Set. then exit the dialog box.

33) File->SaveAs, name it Dx.yy-frontmatter-clean.fm (This is the file to use for future updates after the letter ballot completes).

34) Delete the comment tags in the body. In the Dx.yy-body.fm window, Special->ConditionalText, select “Comments”, Edit, then Delete. Select “Delete the text”, then OK.

35) (Still on ConditionalText dialog box), select Edit, make name “Comments”, Style “As is”, color “Magenta”, then Set, then exit the dialog box.

36) Search (CTRL+F) for "Conditional Text" (change the "Text" to "Conditional Text" to the left of the normal place to enter the search string, and then on the popup window select "RedlineInfo", "<--" (twice), Set). Delete any that are present as documentation of changes that can't be shown by the normal strikethrough/underlining

37) File->SaveAs, name it Dx.yy-body-clean.fm (This is the file to use for future updates after the letter ballot completes).

38) Make a .zip archive of the entire directory, containing all files since last ballot. Send it to TG chair for his records.

8.2 Draft naming

I’m sure there are rules forced on the Chair regarding naming the files submitted to MyBallot, but I don’t know what they are.

The sequence of draft names that appeared for P802.11r were:

P802.11r_7.0.pdf

P802.11r_8-r1.pdf

P802.11r_D9.0-r2.pdf

P802.11r_Draft_9.0-r3.pdf

More data is required. Further text TBD.
8.3 Rules, Rules, Rules, and Timing

Compared to the rules for draft availability for Working Group ballots, the rules during Sponsor Ballot are almost non-existant. The LMSC Policies and Procedures (revision 4 Jan 2006) contain nothing about drafts during Sponsor Ballots. The IEEE-SA Operations Manual (revision Dec 2007) subclause 5.4 contains Sponsor Ballot rules, and nothing places requirements on the technical editor for preparation of drafts.
As a result, everything is up to the discretion of the Chair of the Comment Resolution Committee.

There is some question about exactly who/what constitutes the Comment Resolution Committee.  IEEE-SA rules require that it be appointed by the Sponsor (e.g. chair of LMSC, Paul Nikolich). He has traditionally passed this on to the 802.11 Chair.  The 802.11 WG Chair has either appointed 1) the Task Group Chair, with members being whomever shows up whenever the CRC chair decides to meet, or 2) the Task Group Chair, with members being the entire Working Group.  If the latter, then the comment resolutions need to be approved by the entire Working Group, which means a submission (and a 4-hour rule) and a vote in a plenary session.  If the former, then the comment resolutions can be approved via teleconferences or ad-hoc meetings.
In early February 2008 the view shifted from alternative #2 to alternative #1, without any formal announcement.
9 Final steps: RevCom and IEEE Publications

Once I’ve done this, I may know something about it. Until then, text is guesswork, and based on my notes from Terry describing the process on the Editor’s teleconference 3/31/08.
After the draft is approved by ExCom, the FrameMaker source files need to be included in the package to RevCom. This does not include the source files for the figures.

Once the draft is approved by RevCom and IEEE Standards Board, the source files that were included in the RevCom package are forwarded to the Publications Dept. Also at this point the editor needs to send:

· Source files for each individual figure, one figure/file, with file named appropriately for the figure.
· Errata sheet

Unclear whether a set of upated FrameMaker source files, including the fixes mentioned in the errata sheet, would be appreciated or not.  I’ll be finding out.

IEEE will produce an updated FrameMaker file for publication, with proper boilerplate. Everything they change will be highlighted, and everything they want comments on will be highlighted in another color. They send the Working Group Technical Editor a pdf file (not the FrameMaker source file). The TG editor and the WG editor work through it together and produce one set of answers.
IEEE then generates another PDF which they call the “final draft”, and send it to the WG editor and TG editor. TG editor goes through it and sends the approval to WG editor; WG editor goes through it and sends approval to the WG chair; WG chair sends approval to the IEEE and causes publication.

Total length of time for this process, from sending them the figures/errata to publication, is supposed to be 30 days.

10 Comment Resolution

After a letter ballot, the comments from the voters are collected and managed in a comment resolution spreadsheet.  The editor may be assigned to compile and track comments by the Task Group chair. Other leaders or members in the Task Group may instead keep this database, depending on the Task Group. Assigning this task to the editor has both advantages (e.g., efficiency, organization of comments) and disadvantages (e.g., lack of a check and balance, additional work for the editor). Opinions vary as to whether it is a good idea or not that the editor do this job. In case this additional job is done by the editor, procedures for handling comment spreadsheets are given here.
Throughout this section, the term “Comment Resolution Committee” is used to designate the group that resolves the comments.  After a successful ballot (i.e., approval by more than 75% of those submitting votes, and achieve a return rate of over 75% of the voting pool), the Working Group Chair appoints a Comment Resolution Committee Chair, and a Comment Resolution Committee. For Working Group ballots, this is usually identical to the Task Group that generated the draft.
This comment resolution process applies to ballots that pass. It may optionally be applied to ballots that fail.

10.1 Steps in the comment resolution process

The actual requirements for comment resolution are very simple:

· All comments must be addressed

· The responses to all comments associated with negative votes must be recirculated to the voters

· The responses deemed unsatisfactory by the negative voters must be presented to ExCom before approval for Sponsor Ballot or RevCom.

And, almost incidentally,

· Changes approved in the comment resolutions need to be made to the draft (as covered in 5.3).

The tools to manage the comments and resolutions to those comments vary, and different tools are optimum for different quantities of comments.  This section is written as tool-independent, stating instead just what needs to be done; later sections tell how it can be done with specific tools. While the term “comment resolution database” is used throughout, this could be an Excel spreadsheet, or an MSAccess database, or anything else.
The following sections apply equally to comments received from initial ballots and comments received from recirculation ballots, unless stated otherwise.

10.1.1 Initial sanity checking

Associated with every comment, the voter provides certain pieces of information:

· Page number of the correction needed

· Line number on that page

· Clause number of the correction needed

· Whether the comment is editorial or technical

· Whether the comment is marked “Must be satisfied”.
Experience has shown that a significant percentage of this supplemental information provided is wrong. To make comment processing proceed smoothly, correct information is needed.  It is also useful, if the tools being use allow it, to keep the original information provided by the voter as well as the corrected information. 

Page numbers and line numbers are often mis-entered, either because of typos, or mis-reading. They may also be incorrect because the voter based his/her comments on the redline version of the draft instead of the clean version of the draft (or, for Sponsor Ballots, on the clean version instead of the redline version).  In any case, the person generating the comment resolution database should insert correct information. It is also common for voters to be “off by one” in the line numbers, probably due to the fact that the line numbers don’t exactly line up with the text. The person generating the comment resolution database should be consistent in either using the lower or higher possible line number for each comment.
Clause numbers are occasionally useful for sorting or selecting of the comments, and so should be consistently entered in the comment resolution database. Voters often give incorrect clause numbers, e.g. comments on 8.4.1.1.1b may show in comments as 8.4.1.1.1, or 8.4.1.1b, or 8.4.1.1.1B, or 84411b. Unfortunately they sort differently.  Clause number “general” is often entered for comments that don’t pertain to a specific place in the draft. The page/line for these comments should be set to 0/0.
Comment type should be entered either as “E” (for editorial) or “T” (for technical). If left blank, or invalid, call it technical for now. The decision will be revisited later (in 10.1.3).

If the voter voted to approve the draft, and submitted comments marked as “Must be satisfied”, the approval vote takes precedence.  However, note that the actual voting record is not to be made public. IEEE-SA rules are primarily concerned with comments that are marked “Must be satisfied” and attached to a negative (Disapprove) vote. The “Must be satisfied” is only meaningful is attached to a comment associated with a Disapprove vote, or a comment from a mandatory coordination body (e.g. SCC10, SCC14, SA Editorial Staff, RAC). These are shown in the following diagram from 07/2050r0:

[image: image3]
10.1.2 Duplicates

When there are multiple voters from the same company, the comments often appear similar.  In some cases, the comments appear word-for-word identical.  Any such duplicate comments do not need to be considered by the comment resolution committee multiple times – the resolution approved for the first occurrence should apply to all of them. These copycat comments can be noted in many different ways, depending on the tool being used, but the end effect should be the same.

10.1.3 Editorial vs Technical comments

The Comment Resolution Committee Chair has the authority to reclassify comments that are submitted.  Some things are clearly editorial, and some things are clearly technical. Other items are less clear. Any change that affects interoperability, or the air or other interface, is clearly technical. Any comment that changes behaviour from normative to optional, or from optional to normative, is clearly technical. Any comment that concerns only grammar, spelling, punctuation, abbreviation, word usage, font, font size, font style, headings, figure or table titles, frontmatter material, formatting bibliography and references, and creating and using acronyms is clearly editorial. Any comment that concerns only (re)numbering items, clause and sub-clause titles, table and figure captions, moving and organizing text, are clearly editorial. Changing “<ANA>” to an assigned number, and changing an editor’s note or footnote is also clearly editorial. If in doubt for middle ground, choose technical. The choices are shown in the following diagram:

[image: image4]
The Comment Resolution Committee Chair may delegate the editorial comments to the editor, and instruct the editor to report back to the body by a specific time on editorial comments that may have technical impact. The editor may request non-binding straw polls as guidance. The Comment Resolution Committee Chair then rules on whether these comments are reclassified or not. The Comment Resolution Committee Chair may also ask the body if any editorial comments should be reclassified as technical, and the Comment Resolution Committee Chair rules if they are reclassified.
10.1.4 Comment validity

Sometimes comments are submitted that give no clear guidance of what should be changed in the draft. An example is a comment that states “Alternatives X, Y, and Z should be considered to the method in the draft” without providing a proposed resolution. Another example is a proposed resolution that promises a submission, but that submission is not delivered. While such comments may be considered appropriate in an initial ballot, or a long grace period for the submission may be given, such comments should not be submitted in a recirculation ballot.
The IEEE-SA Operations Manual, in 5.4.3.1, states quite clearly that a negative vote “must be accompanied by one or more specific objections with proposed resolution in sufficient detail in a legible form so that the specific wording of the changes that will cause the negative voter to change his or her vote to "approve" can readily be determined.”
The Comment Resolution Committee Chair has the authority to rule comments invalid that don’t meet these requirements. The editor is the person most qualified to determine whether the proposed resolution to a comment meets the requirements given in 5.4.3.1, and should be the person requesting the ruling. For an analysis of such a request, see 06/1766r1.

Any comments ruled invalid by the Comment Resolution Committee Chair should be resolved as:

Rejected. This comment was ruled invalid according to the criteria for valid comments in the IEEE-SA Operating Procedures.

As with all comments by the Disapprove voters, this resolution needs to be recirculated in the next ballot.
10.1.5 Scope of recirculation ballots

In a recirculation ballot the scope of comments is limited. Clause 5.4.3.2 of the IEEE-SA Operations Manual states:

During a recirculation ballot, balloting group members shall have an opportunity to change their previously cast ballots. A change to “do not approve,” which is submitted with comments, shall be based only on the changed portions of the balloted document, clauses affected by the changes, or portions of the balloted document that are the subject of the unresolved negative votes. If a change to “do not approve” is based solely on comments concerning previously approved portions of the balloted document, the balloter shall be informed that the comments are not based on the changed portion of the balloted document. Such comments need not be addressed in the current ballot and may be considered for a future revision of the standard.

The first of these conditions, “changed portions of the balloted document”, is simple to determine by examination of the redline version of the draft. The third condition, “subject of the unresolved negative votes”, is simple to determine by examination of the recirculated comments from the previous ballot. The second condition, “clauses affected by the changes”, is more complex, and involves the judgement of the Comment Resolution Committee Chair. In its most expansive interpretation, it may mean any comment on a top-level clause (e.g. clause 8, clause 11, etc) that contains a change from the previous draft. In its most restrictive interpretation, it may mean a comment is technically related to a change from the previous draft. Guidelines for the Comment Resolution Committee Chair would certainly be nice.
Comments that are ruled out of scope of the recirculation ballot should be resolved as:

Rejected. This comment is out of scope of this recirculation ballot.

Comments that are ruled out of scope of a Working Group recirculation ballot may be deferred and submitted by the Chair as comments in the initial Sponsor Ballot. Such comments should be resolved as:

Rejected. This comment is out of scope of this recirculation ballot. It will be submitted by the Comment Resolution Committee Chair during the initial Sponsor Ballot.

Comments that are deferred for the initial Sponsor Ballot need to be maintained in the comment resolution database.

Comments ruled out of scope during a Sponsor Ballot recirculation should be submitted by the voter as comments in the next revision of the standard.  Such comments should be resolved as:

Rejected. This comment is out of scope of this recirculation ballot. It should be submitted during the next revision of the standard.

10.1.6 Handling of non-required editorial comments

The Comment Resolution Committee Chair may entertain a motion to adopt a resolution for all Editorial comments not attached to disapprove votes or note marked as “Must be satisfied” as:

This comment is deemed editorial a delegated to the document editor for consideration in developing future drafts. Please note that the IEEE standards are edited professionally prior to publication.

Editors may provide additional notes on what they do with comments, but these are not part of the formal comment response and may be created after comment resolution is completed.

The editor shall be diligent to incorporate as many of these as is feasible to improve the editorial maturity of the draft. However,

· Not all editorial comment proposals are valid solutions. The editor is not bound to act positively on all editorial comments delegated to the editor.

· Not all comments delegated to the editor may be acted on immediately. The editor will have a work plan that calls for doing some changes at a later time or together with other changes.

· Some items delegated to the editor may be referred by the editor to the IEEE staff to be addressed during professional editing prior to publication by IEEE staff.

Alternatively, non-required editorial comments may be handled identically to required editorial comments.

10.1.7 Handling of required editorial comments

The editor is expected to bring forward proposed comment resolutions for all editorial comments attached to disapprove votes and marked as “Must be satisfied”, and may bring forward proposed comment resolutions for other editorial comments.  The comment resolution body considers the proposal, and adopts a resolution. An appropriate response could be many things but will ultimately be determined by acknowledgement or acceptance by the voter, and agreement by the ballot group, process review by ExCom, RevCom, etc. Examples of possible resolutions include:

· Accepted. State what will be done.

· Rejected. State why.

· Accepted. This change will be implemented by IEEE-SA Editorial Staff prior to publication.

· Accept in principle. The Working Group will request that IEEE-SA Editorial Staff review this comment prior to publication and implement changes are required by their editorial guidelines.
10.1.8 Handling of technical comments
The editor is a member of the Comment Resolution Committee, and is entitled to bring forward proposed comment resolutions to the technical comments. The comment resolution body considers the proposal, and adopts a resolution.

10.1.9 Voter feedback and comment carryover
All comments associated with disapprove votes must be available to voters during the following recirculation ballot, as they may change their vote on the basis of new comments with which they agree, even if there are no other text changes.

All comments from a disapprove voter, and their resolutions, should be sent to that voter for approval. The voter may accept the resolution to the comments, or indicate that they are still unsatisfied with some or all of the resolutions. Lack of response from the voter is taken as an indication of dissatisfaction. The voter changing their vote to Approve indicates acceptance of all their previous comments. All unsatisfied comments from the remaining disapprove voters are presented to ExCom with a request to move the draft toward publication.

10.2 Tools

There are two tools commonly used to manage comments and resolutions after a ballot. They are Excel and MSAccess.

Excel makes an excellent tool for managing the comment resolution database. It is understood by most of the voters and comment resolution committee members. It has powerful facilities for sorting and selecting (though these are generally not well understood by the comment resolution committee members). It is easy to extend, and can be used to generate many fancy charts and status reports.And possibly more importantly, as a Microsoft Office Application (assuming it includes the template information described in http://ieee802.org/11/Documents/format-rules.html), satisfies the requirements of submissions as given in 2.5 of the 802.11 P&P.

MyBallot_V4p4Plus (copy is embedded here 
[image: image5.emf]MyBallot_V4p4Plus.m db

) is an extension
 of a tool written in 802.3 for use in ballots, and interfaces well to the IEEE MyBallot system. It is based on MSAccess, and will be referred to in this document as the ACRT (Access Comment Resolution Tool). While MSAccess is technically part of Microsoft Office, and the 802.11 P&P allow any Microsoft Office application to be submitted to the document server, this has not in the past been allowed. Therefore all reports produced by ACRT are generated as pdf files, which are only discouraged (not disallowed) on the document server.

In addition, there are certain tools that have been developed within 802.11 that assist in using ACRT.

ExportMyBallotToExcel (embedded here 
[image: image6.emf]ToExcel.mdb

) is a tool that converts an MSAccess database generated by ACRT to an Excel spreadsheet: 

ExportExcelToTilde (embedded here 
[image: image7.emf]ToTilde.mdb

) is a tool that converts an Excel spreadsheet into a “Tilde” file for later importing into ACRT.

CSV-fix (embedded here 
[image: image8.emf]csv-fix.EXE

) is a tool that fixes newlines between double quotes, which are not handled very well by either Excel nor the IEEE MyBallot system.  When needed, this program must be run in a “CommandPrompt” window.
In general, ACRT is the optimum tool for Sponsor Ballot comments, when the quantity of comments is on the order of one hundred.  Excel is better for Working Group ballots, and for Sponsor ballots with more than a few hundred comments. If the number of comment is very large (e.g., over 50K), then neither tool is good.
ACRT is the only way to generate the report needed for ExCom to forward the draft to Sponsor Ballot or to RevCom. Therefore, an understanding of both tools is unfortunately necessary.

10.3 Using Excel as comment resolution tool

There are many current examples of Excel spreadsheets being used for comment resolution. These include:

TGk: 11-08-0266-02-000k-11k-sb-recirc-5-comment-resolutions.xls

TGn: 11-07-2687-04-000n-tgn-lb115-composite-comments.xls
TGp: 11-07-2481-09-000p-lb110-tgp-comment-resolution-master.xls
TGr: 11-08-0229-00-000r-d9-comments.xls
TGs: 11-07-0023-55-000s-lb93-tgs-draft-1-0-comment-spreadsheet.xls

TGT: 11-07-0659-25-000t-lb101-comment-resolution.xls
TGu: 11-08-0326-05-000u-lb122-comment-spreadsheet.xls
TGv: 11-07-2368-06-000v-lb-108-comment-resolutions.xls
TGw: 11-08-0261-04-000w-lb121-comment-resolution.xls
TGy: 11-08-0277-04-000y-d8-comments-spreadsheet.xls
The lineage of each of these can be traced back to one of a very small number of progenitors.
The following discussion is not based on any of the above spreadsheets, but rather on 20-20 hindsight.
In the overall flow from ballots to publication, the comment resolution spreadsheet appears in the middle of four separate sequences:

WG Voter input -> Spreadsheet -> Supporting documentation for next recirculation ballot

WG Voter input -> Spreadsheet -> Report to ExCom for Sponsor Ballot approval

SB Voter input -> Spreadsheet -> Supporting documentation for next recirculation ballot

SB Voter input -> Spreadsheet -> Report to ExCom for RevCom approval

While it is possible that each of the four spreadsheets in the above sequences be designed differently (and has been done that way several times in the past), it is the goal of this Editor’s Manual to use one spreadsheet design that serves all purposes. The spreadsheet described here can be built easily from either WG voter input or from SB voter input, and can produce both the supporting documentation needed for recirculation ballots and also the Report to ExCom for moving the draft forward.
The basic structure of a comment resolution spreadsheet is to have one worksheet called “comments” – on that worksheet one row for each comment, and one column for each attribute of a comment. The first row should be column titles. In order to interface with the tools generating the reports for ExCom, the columns should include the following (with the heading in row 1 exactly as given here, so that it corresponds to the field name in the MyBallot tools):

	Heading (row 1)
	Description of the data in this column

	CommentID
	Sequential integer assigned by the editor for WG ballots, assigned by MyBallot for Sponsor Ballots. When under the control of the editor, it is best if the CommentID match the row number (see sorting, later)

	CommenterName
	Name of the voter who submitted this comment

	CommenterAffiliation
	Affiliation of the voter who submitted this comment

	Subclause(Ed)
	As determined by editor

	Page(Ed)
	As determined by editor

	Line(Ed)
	As determined by editor

	CommentType
	For WG ballots, this is determined by editor and/or CRC Chair; it is a combination of the Type and MustBeSatisfied, and contains “E”, “ER”, “T”, “TR”, “G”, or “GR”. For Sponsor Ballots, this field is provided by MyBallot.

	Subclause
	As provided by voter

	Page
	As provided by voter

	Line
	As provided by voter

	WG: Type

SB: not present
	As provided by voter. During WG ballots this is either “E” or “T”. 

	WG: MustBeSatisfied

SB: not present
	As provided by voter, during WG ballots. Column not present for Sponsor Ballots.

	Comment
	As provided by voter

	SuggestedRemedy
	As provided by voter

	CommentStatus
	Filled in by Comment Resolution Committee, either “A” for Accept, or “R” for Reject

	Response
	Filled in by Comment Resolution Committee, giving details of the acceptance or rejection of the comment.  If CommentStatus is “A”, then this field may be empty; otherwise text is required. The words “Accept”, “Reject”, or “Accept in principle” may appear at the beginning of the response; if they appear they need to match the CommentStatus field.

	ResponseStatus
	Filled in by editor, either “C” for Closed, or “U” for Unsatisfied


Note the order of the columns does not matter to the tools. 

Other columns may be added to the spreadsheet, depending on the desires of the editor and Comment Resolution Committee. It is important that these have distinct headings in row#1 of the worksheet (i.e. don’t conflict with the headings above, or there will be chaos later). Some examples that have proven useful are:
	Heading (row 1)
	Description of the data in this column

	CID
	Useful especially for Sponsor Ballots, since the value of CommentID is assigned by MyBallot.  It provides an easier “name” for the comment.

	Pg.ln
	Combination of page number and line number, formatted as a 2-digit decimal value. This provides a single column for sorting (as opposed to first sorting by the Line column, then sorting by the Page column). Minimal usefulness.

	Resolution
	Values selected from a pull-down menu, either “Accepted” “Declined”, “Counter”, or “Deferred”. The row color can be made dependent on this field, for rapidly finding open items.

	Group#
	A small integer, useful for identifying groups of comments that can be included in a single motion – “Move to accept the resolutions to all comments marked in Group# 1”, as opposed to “Move to accept the resolutions to CIDs 113, 308, 317, and 117.”

	SameAs
	An indication that this comment is identical to another, and that it does not need to be considered separately

	EditorStatus
	Filled in by the Editor as the resolutions are incorporated into the draft.

	EditorNotes
	Any comments from the Editor while incorporating into the draft. Examples are the draft number that includes the resolution.

	EmailDate
	Date of a response from the voter that approved the resolution to his/her comment


10.3.1 Generating an initial comment spreadsheet after a Working Group ballot
The initial comment spreadsheet is built from the document submission template
.  After entering the proper information on the “Title” sheet, rename “Sheet1” to “Comments” (click on the “Sheet1” tab at the bottom of the window, then click Format->Sheet->Rename, type the new name “Comments”, then press Enter. Enter row#1 of the Comments sheet from the table of required fields above. While the order is not critical, the procedure is easiest of the columns for Clause, Page, Line, Type, Required, Comment, and Recommended change are adjacent and in that order.
The output of a Working Group ballot is a collection of Excel spreadsheets, one spreadsheet from each voter that is submitting comments.  Each of those spreadsheets is based on the template provided to the voters, and includes seven columns: Clause, Page, Line, Type, Required, Comment, and Recommended change. For each of these voter-provided spreadsheets, select the contents of all seven columns for all rows filled in, copy them to the clipboard (Ctrl-C), switch to the combined spreadsheet, select the cell in the “Clause” column in the next higher row, and paste the clipboard contents (Ctrl-V).  Fill in the CommenterName and CommenterAffiliation on each row (type it once, select the contents of those two cells, copy to clipboard, select the CommenterName cell on each row, then paste).
After all of the voter-provided spreadsheets have been processed, the fields need to be sanity-checked according to the procedures given in 10.1.1 through 10.1.5. 
Sorting the comments by page number, and within each page by line number places all similar comments together in the spreadsheet, and makes it easier to see the complete changes being requested (first select one of the cells in row#1 and click Data->Filter->AutoFilter; then click on the pull-down menu in the “Line(Ed)” column, and select “Sort ascending”; then click on the pull-down menu in the “Page(Ed)” column and select “Sort ascending”). Now set the CommentID field to be sequential integers matching the row number in the spreadsheet ((assume the CommentID is column A) insert a value 2 in cell A2, and the formula “=A2+1” in cell A3. Select cell A3 and copy to clipboard (Ctrl-C). Select cell A4 and press “PgDn” until all rows of the spreadsheet are selected. Press paste (Ctrl-V). Now the value are set, but at the expense of CPU time. Select the entire column by left-clicking on the “A” at the top of the spreadsheet, and copy to clipboard (Ctrl-C). Click Edit->PasteSpecial, and select Values, then click OK. Done).
10.3.2 Generating an initial comment spreadsheet after a Sponsor Ballot

The initial comment spreadsheet is built from the document submission template. Enter the proper information on the “Title” sheet.

The output of a Sponsor Ballot is a “comma-separated-value” file. It can’t be imported directly to Excel due to various incompatibilities with the handling of embedded newlines in quoted strings.  Best procedure is to build an MSAccess database with the Sponsor Ballot comments. Click on the embedded MyBallot MSAccess database in 10.2, and press Ctrl-C. Switch to a Windows Explorer window, select a temporary folder, and press Ctrl-V. The file MyBallot_V4p4Plus.mdb will be created in that folder. Rename it to temp.mdb, then double-click on it. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click the large button marked “Input” next to “Input comment file: Tilde, MyBallot or FileMaker format”. Click the button at the top marked “Select input datafile”, and select the csv file obtained from the MyBallot system. In the purple box labelled “MyBallot comment database input” (leftmost set of buttons), click “MyBallot database file (*.csv, *.xls) Rough Import”, then when it gives the record count click “OK”. Next click “Transfer new and updated records to Main table”, and then “OK” twice.  Save the MSAccess database (Ctrl-S, or File->Save, or just exit).
Next convert the MSAccess database to an Excel spreadsheet. Double click the icon for ExportMyBallotToExcel in 10.2 to run the conversion. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Once the tool is open, click “Select MyBallot Database file”, and select the temporary MSAccess database previously saved. Click “Select target Excel file”, and select the initial comment spreadsheet file. Click “Perform Export”.  If it stops with a Visual Basic debugging breakpoint, close the debug window (the “x” in the upper right corner does it), and click “Perform export” again.  When it says “Complete”, click OK and close MSAccess. 

The Excel spreadsheet now includes all the comments from the Sponsor Ballot voters. Insert additional columns in the spreadsheet, with titles (data in row#1) CID, Page(Ed), Line(Ed), Clause(Ed), and any others desired.

The fields in the spreadsheet are now ready to be sanity-checked according to the procedures given in 10.1.1 through 10.1.5. 
Sorting the comments by page number, and within each page by line number places all similar comments together in the spreadsheet, and makes it easier to see the complete changes being requested (first select one of the cells in row#1 and click Data->Filter->AutoFilter; then click on the pull-down menu in the “Line(Ed)” column, and select “Sort ascending”; then click on the pull-down menu in the “Page(Ed)” column and select “Sort ascending”). Now set the CID field to be sequential integers matching the row number in the spreadsheet ((assume the CID is column A) insert a value 2 in cell A2, and the formula “=A2+1” in cell A3. Select cell A3 and copy to clipboard (Ctrl-C). Select cell A4 and press “PgDn” until all rows of the spreadsheet are selected. Press paste (Ctrl-V). Now the value are set, but at the expense of CPU time. Select the entire column by left-clicking on the “A” at the top of the spreadsheet, and copy to clipboard (Ctrl-C). Click Edit->PasteSpecial, and select Values, then click OK. Done).
10.3.3 Recording resolved comments

As comment resolutions are written, they should be entered in the “Response” column. When the resolution is approved by the Comment Resolution Committee, the entry in the “CommentStatus” column should be changed to “A” if the comment is accepted (or accepted in principle or Countered); the entry in the “CommentStatus” column should be changed to “R” if the comment is rejected. When there are no more “X” values in CommentStatus, then the job is done.

When there are large numbers of comments, a separate motion approving each resolution is rather cumbersome. One way that has been found to work well is to include a column in the spreadsheet labelled “Group#”, and put a value in the cells in that column that identify a block of comments that are considered in a single motion.  The motion can then be “Moved to accept the resolutions of all comments marked in Group# 1 in spreadsheet 11-08-xxxx….” The members of the Comment Resolution Committee can see all of these comments by using the selector in Excel – in the cell in row#1, click the pull-down menu button and click on “1” and all rows with Group# set to 1 will appear.

10.3.4 Generating report of resolutions for a Working Group recirculation

This is particularly easy if Excel is being used as the comment resolution tool. The latest version of the spreadsheet qualifies as the report of resolutions for a Working Group recirculation ballot.

10.3.5 Generating report of resolutions for a Sponsor Ballot recirculation

After the Comment Resolution Committee has completed processing all the comments from a Sponsor Ballot, the resolutions need to be uploaded into the IEEE MyBallot system. This involves two steps – first transferring the resolutions into an MSAccess database, and secondly generating the csv file for upload to MyBallot.

The interface between Excel and MSAccess for doing this is called a “tilde” file. To generate such a file, double-click the icon for ExportExcelToTilde in 10.2 to start the tool. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click “Select Comments Spreadsheet”, and select the Excel file that contains the final comments. Next click on the name of the sheet that contains the resolutions, typically “Comments”. Click “Select output file and perform export”, and set the place to store the output tilde file.
Next the tilde file is imported into the MSAccess database.  Make a fresh copy of the MyBallot MSAccess database – click on the embedded MyBallot MSAccess database in 10.2, and press Ctrl-C. Switch to a Windows Explorer window, select a temporary folder, and press Ctrl-V. The file MyBallot_V4p4Plus.mdb will be created in that folder. Rename it to temp.mdb, then double-click on it. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click the large button marked “Input” next to “Input comment file: Tilde, MyBallot or FileMaker format”. Click the button at the top marked “Select input datafile”, and select the tilde file generated above. In the box labelled “Tilde comment file input”, click “Tilde file (*.txt) Rough Import”, then when it gives the record count click “OK”. Next click “Transfer Rough records to Main table”, and then “OK”.  Click “Return to Start menu”.
Next the comment resolutions are exported in MyBallot csv format. Adjacent to “Output comment file: Tilde or MyBallot CSV”, click the button marked “Output”. Click “Output ALL comments: MyBallot CSV format”.

Unfortunately the CSV file generated by the MyBallot MSAccess database isn’t quite the right format for uploading to the IEEE MyBallot system. Any comment resolution that has an embedded newline character doesn’t export into the CSV file correctly. Maybe someday it will get fixed; until then a simple program that makes the necessary changes to the file is csv-fix, embedded in 10.2. Select the icon for csv-fix and then press Ctrl-C. Switch to a Windows Explorer window, select the folder in which the CSV file was placed, and press Ctrl-V.  Open a “Command Prompt” window (in WinXP, this can be found Start->AllPrograms->Accessories->CommandPrompt). In the command prompt window, switch to the same directory that contains the CSV file and the csv-fix program, and enter the command “csv-fix <MyBallot.csv >MyBallot-fixed.csv”. 
Now the file “MyBallot-fixed.csv” is ready to upload to the IEEE MyBallot system as the final resolutions of the comments in this letter ballot.

10.3.6 Recording satisfaction/unsatisfaction of voter

Once the comment processing is complete, and a recirculation ballot is starting, the comment resolution spreadsheet column labelled “ResponseStatus” should be set. For comments that are not marked as “Must be satisfied”, the Response status is set to “C” (for “Closed”). All other comments are set to “U” (for “Unsatisfied”) until the voter acknowledges they are satisfied with the resolution. The spreadsheet page should be renamed to, e.g., “Initial ballot”, “first recirculation”, etc. This makes room for a new spreadsheet page named “Comments” for the next ballot.

Ideally the voter who submitted comments with his/her disapprove vote will be present when the comments are resolved. But even if they are present, they often won’t commit to being satisfied with the resolution at that time. IEEE rules require the voter to respond in writing that they are satisfied with the resolutions to their comments before they can be considered “closed”.

The voters who voted “disapprove” (or maintained a “disapprove” vote through a recirculation ballot) should be asked after each ballot whether they are satisfied with the resolution to their comments.  Lack of response indicates lack of approval.  If they indicate they are satisfied, then the entry in the “ResponseStatus” should be changed to “C” (for “Closed”).
If the voter indicates through an email that they are withdrawing their comment, the ResponseStatus for that comment should be changed to “Z”.

A voter who changes their vote from disapprove to approve does not need to send an explicit email indicating acceptance of the resolutions to their comments – it is implied by their new vote. All of their comments should have the “ResponseStatus” changed to “C”.

10.3.7 Generating report of unsatisfied comments for ExCom

The report to ExCom, also called the “Fancy Committee Report”, is generated out of the MSAccess ACRT database. At the point this is done there should be very few unsatisfied comments, so the procedure seems especially cumbersome for small output.

A separate report pdf file is generated for each ballot in which there are unsatisfied comments. So if there were three recirculations performed, there could be up to four reports (initial ballot, and each of the three recirculations). The following procedure is done for each of the ballots.

First generate a tilde file. Double-click the icon for ExportExcelToTilde in 10.2 to start the tool. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click “Select Comments Spreadsheet”, and select the Excel file that contains the final comments. Next click on the name of the sheet that contains the resolutions from the desired ballot. Click “Select output file and perform export”, and set the place to store the output tilde file.

Next the tilde file is imported into the MSAccess database.  Make a fresh copy of the MyBallot MSAccess database – click on the embedded MyBallot MSAccess database in 10.2, and press Ctrl-C. Switch to a Windows Explorer window, select a temporary folder, and press Ctrl-V. The file MyBallot_V4p4Plus.mdb will be created in that folder. Rename it to temp.mdb, then double-click on it. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click the large button marked “Input” next to “Input comment file: Tilde, MyBallot or FileMaker format”. Click the button at the top marked “Select input datafile”, and select the tilde file generated above. In the box labelled “Tilde comment file input”, click “Tilde file (*.txt) Rough Import”, then when it gives the record count click “OK”. Next click “Transfer Rough records to Main table”, and then “OK”.  Click “Return to Start menu”.

On the Start menu, click “Utilities”. Fill in the “Global settings” with the name of the draft that generated the current set of comments, and fill in the Project title with the name of the Task Group. Click “Update Now” and then click “Return to Start menu”. In the “Database” window (identified by the list Objects, Tables, Queries, Forms, Reports, Pages, Macros, Modules, etc on the left side of the window), click on “Reports” and then select “Committee report_Clause” and then click “Design” on the top toolbar. A new window will open called “Committee report_Clause: Report” In that window, the bottom right corner should contain the name and affiliation of the person responsible for the report (either the editor, or Chair). Replace the text with the proper name and affiliation. Click the “X” in the top right corner of the report window, and click “Yes” for saving the changes.
On the Start menu, click “Reports”. On the “Final Reports” menu, under “Sort records by” select “Clause, subcl, page, line”; under “Comment type list” select “Unresolved TR/ER/GR Comments”, and then click “Fancy Committee Report”. Print that report by clicking File->Print, select “Acobe PDF” as the printer, click “OK”, and provide a name for the output pdf file.

The collection of all pdf reports generated above, one for each ballot that contained unsatisfied comments, is included in the Chair’s report to ExCom for approval of the draft.

10.4 Using MSAccess as comment resolution tool

An MSAccess tool was written by IEEE and interfaces well to the IEEE MyBallot system. It is referred to in this document as the ACRT (Access Comment Resolution Tool). It can also be used for Working Group ballots.
10.4.1 Generating an initial comment database after a Working Group ballot
The output of a Working Group ballot is a collection of Excel spreadsheets, one spreadsheet from each voter that is submitting comments.  Each of those spreadsheets is based on the template provided to the voters, and includes seven columns: Clause, Page, Line, Type, Required, Comment, and Recommended change.

The initial database for ACRT after a Working Group ballot is most easily constructed by first generating a combined Excel spreadsheet of all the submissions by the voters.  First create a new Excel spreadsheet (no need to follow the 802.11 submission template for this one). On Sheet1, enter row#1 with the values “CommenterName”, “CommenterAffiliation”, “Subclause”, “Page”, “Line”, “Type”, “MustBeSatisfied”, “Comment”, “SuggestedRemedy”, “CommentID”, and “CommentType”.

For each of these voter-provided spreadsheets, select the contents of all seven columns for all rows filled in, copy them to the clipboard (Ctrl-C), switch to the combined spreadsheet, select the cell in the “Subclause” column in the next higher row, and paste the clipboard contents (Ctrl-V).  Fill in the CommenterName and CommenterAffiliation on each row (type it once, select the contents of those two cells, copy to clipboard, select the CommenterName cell on each row, then paste).

After all of the voter-provided spreadsheets have been processed, the CommentID and CommentType need to be entered. In row#2 (the first comment), enter the formula =if (F2=”E”,”E”,”T”)&if(G2=”Y”,”R”,””). This will combine the Type column and the MustBeSatisfied column into a single value, E/ER/T/TR. Copy this formula to all cells in column K (Note that when a formula is copied in Excel, it adjusts the cell references so that the formula in each row references the values in that row). In row#2 for the CommentID, enter 1. In row#3 for the CommentID, enter =J2+1. Copy this formula to all remaining cells in column J (note that when this formula is copied in Excel, it adjusts the cell reference so that the formula in each row references the value in the previous row). Next select the two columns J and K – left-click the letter “J” above row#1 (selecting column J), and press the right arrow key to also select column K. Press Ctrl-C to copy these columns to the clipboard. Click Edit->PasteSpecial, then select “Values” and click “OK”. The formulas are now gone and replaced with actual values.
Next generate a tilde file from the Excel spreadsheet. Double-click the icon for ExportExcelToTilde in 10.2 to start the tool. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click “Select Comments Spreadsheet”, and select the Excel file that contains the combined comments. Next click on the name of the sheet that contains the comments, likely “Sheet1”. Click “Select output file and perform export”, and set the place to store the output tilde file.

Next the tilde file is imported into the MSAccess database.  Make a fresh copy of the MyBallot MSAccess database – click on the embedded MyBallot MSAccess database in 10.2, and press Ctrl-C. Switch to a Windows Explorer window, select the folder that will be storing all the files for this ballot, and press Ctrl-V. The file MyBallot_V4p4Plus.mdb will be created in that folder. Rename it to ACRT-InitialBallot.mdb (or ACRT-Recirculation1.mdb, etc), then double-click on it. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click the large button marked “Input” next to “Input comment file: Tilde, MyBallot or FileMaker format”. Click the button at the top marked “Select input datafile”, and select the tilde file generated above. In the box labelled “Tilde comment file input”, click “Tilde file (*.txt) Rough Import”, then when it gives the record count click “OK”. Next click “Transfer Rough records to Main table”, and then “OK”.  Click “Return to Start menu”.

On the Start menu, click “Utilities”. Fill in the “Global settings” with the name of the draft that generated the current set of comments, and fill in the Project title with the name of the Task Group. Click “Update Now” and then click “Return to Start menu”. In the “Database” window (identified by the list Objects, Tables, Queries, Forms, Reports, Pages, Macros, Modules, etc on the left side of the window), click on “Reports” and then select “Committee report_Clause” and then click “Design” on the top toolbar. A new window will open called “Committee report_Clause: Report” In that window, the bottom right corner should contain the name and affiliation of the person responsible for the report (either the editor, or Chair). Replace the text with the proper name and affiliation. Click the “X” in the top right corner of the report window, and click “Yes” for saving the changes.

The now fields need to be sanity-checked according to the procedures given in 10.1.1 through 10.1.5. On the Start menu, click “Comment Resolution Screen”. As the ACRT does not have separate fields defined in the database for the editor-corrected values, just update the values in the Main Table.
10.4.2 Generating an initial comment database after a Sponsor Ballot

The output of a Sponsor Ballot is a “comma-separated-value” file. Make a fresh copy of the MyBallot MSAccess database – click on the embedded MyBallot MSAccess database in 10.2, and press Ctrl-C. Switch to a Windows Explorer window, select the folder that will be storing all the files for this ballot, and press Ctrl-V. The file MyBallot_V4p4Plus.mdb will be created in that folder. Rename it to ACRT-InitialBallot.mdb (or ACRT-Recirculation1.mdb, etc), then double-click on it. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Click the large button marked “Input” next to “Input comment file: Tilde, MyBallot or FileMaker format”. Click the button at the top marked “Select input datafile”, and select the csv file obtained from the MyBallot system. In the purple box labelled “MyBallot comment database input” (leftmost set of buttons), click “MyBallot database file (*.csv, *.xls) Rough Import”, then when it gives the record count click “OK”. Next click “Transfer new and updated records to Main table”, and then “OK” twice.  Click “Return to Start menu”.

On the Start menu, click “Utilities”. Fill in the “Global settings” with the name of the draft that generated the current set of comments, and fill in the Project title with the name of the Task Group. Click “Update Now” and then click “Return to Start menu”. In the “Database” window (identified by the list Objects, Tables, Queries, Forms, Reports, Pages, Macros, Modules, etc on the left side of the window), click on “Reports” and then select “Committee report_Clause” and then click “Design” on the top toolbar. A new window will open called “Committee report_Clause: Report” In that window, the bottom right corner should contain the name and affiliation of the person responsible for the report (either the editor, or Chair). Replace the text with the proper name and affiliation. Click the “X” in the top right corner of the report window, and click “Yes” for saving the changes.

The now fields need to be sanity-checked according to the procedures given in 10.1.1 through 10.1.5. On the Start menu, click “Comment Resolution Screen”. As the ACRT does not have separate fields defined in the database for the editor-corrected values, just update the values in the Main Table. Pressing PgDn (or clicking the right arrow on the bottom status line of the window) moves to the next comment.
10.4.3 Recording resolved comments

This section needs to be re-written by someone who has actually used the ACRT, and knows how to use it efficiently. While the following will work, it is extremely cumbersome.

After opening the MSAccess ACRT, press “Comment Resolution Screen” on the Start menu. The comments are now displayed one at a time in a window called “Main Table”.

At a resolution-writing session, the first step is to select the comments needing attention. Under “filter records by status” select “Response not written” and click “Apply Filter/Sort”. It is also possible to select only one type of comment (Editorial or Technical or General), and to sort the selected comments in several different ways. When a proposed comment resolution is decided, it is entered into the Main Table. To the right of the “Response” box, select “proposal mode”. If the comment is proposed to be accepted, press the smiley. If the comment is proposed to be accepted in principle, click the pencil (and write further text in the “Response” box). If the comment is proposed to be rejected, press the frownie (and write further text in the “Response” box). Pressing PgDn (or clicking the right arrow on the bottom status line of the window) moves to the next comment.
When selecting “Response not written” and clicking “Apply Filter/Sort” results in a blank screen, then all comments have a written response.

When the proposed resolutions are approved by the Comment Resolution Committee, all of those entries in the Main Table need to be updated. Under “filter records by status” select “Rdy for committee action” and click “Apply Filter/Sort”. To the right of the “Response” box, select “final mode”. If the proposed response is to Accept, click the smiley; if the proposed response is to Accept in Principle, click the pencil; if the proposed response is to Reject, click the frownie. If the comment was a required comment, ACRT will then ask “Does the commentor accept this resolution?” and you select yes or no (unless the commentor has replied in writing, the answer is “no”). Press PgDn (or click the right arrow on the bottom status line of the window) to move on to the next comment.
When selecting “Rdy for committee action” and clicking “Apply Filter/Sort” results in a blank screen, then all comments have been approved by the Comment Resolution Committee.
10.4.4 Generating a report of resolutions for a Working Group recirculation

There are two alternatives for the report of resolutions for a Working Group recirculation. Both have been used in the past; the choice is up to the Chair.  One alternative is to generate a “Fancy Committee Report” (like the one that is sent to ExCom), and submit a pdf file to the documentation server. The other alternative is to convert the MSAccess database into an Excel spreadsheet, and post the xls file to the documentation server.

First alternative (used by TGma during the 2007 revision of 802.11) is to generate the Fancy Committee Report. After opening the ACRT file for this ballot, click “Reports” on the Start menu. On the “Final Reports” menu, under “Sort records by” select “Clause, subcl, page, line”; under “Comment type list” select “All Comments”, and then click “Fancy Committee Report”. Print that report by clicking File->Print, select “Acobe PDF” as the printer, click “OK”, and provide a name for the output pdf file.

Second alternative (used by TGk during their Sponsor Ballot) is to convert the MSAccess database into an Excel spreadsheet. The initial comment resolution report is built from the document submission template. Enter the proper information on the “Title” sheet. Next convert the MSAccess database to an Excel spreadsheet. Double click the icon for ExportMyBallotToExcel in 10.2 to run the conversion. If it asks about blocking unsafe expressions, answer No. If it asks whether you want to open the file, since unsafe expressions are not blocked, answer Yes. If it asks whether you want to open the file or cancel the operation, answer Open.This sequence of three warnings occurs (for me) every time I open an MSAccess file.  Once the tool is open, click “Select MyBallot Database file”, and select the ACRT database for this ballot. Click “Select target Excel file”, and select the comment resolution report file. Click “Perform Export”.  If it stops with a Visual Basic debugging breakpoint, close the debug window (the “x” in the upper right corner does it), and click “Perform export” again.  When it says “Complete”, click OK and close MSAccess. 
10.4.5 Generating a report of resolutions for a Sponsor Ballot recirculation

After opening the ACRT database for the current ballot, click the button marked “Output” on the Start menu adjacent to “Output comment file: Tilde or MyBallot CSV”. Click “Output ALL comments: MyBallot CSV format”.

Unfortunately the CSV file generated by the MyBallot MSAccess database isn’t quite the right format for uploading to the IEEE MyBallot system. Any comment resolution that has an embedded newline character doesn’t export into the CSV file correctly. Maybe someday it will get fixed; until then a simple program that makes the necessary changes to the file is csv-fix, embedded in 10.2. Select the icon for csv-fix and then press Ctrl-C. Switch to a Windows Explorer window, select the folder in which the CSV file was placed, and press Ctrl-V.  Open a “Command Prompt” window (in WinXP, this can be found Start->AllPrograms->Accessories->CommandPrompt). In the command prompt window, switch to the same directory that contains the CSV file and the csv-fix program, and enter the command “csv-fix <original.csv >MyBallot-fixed.csv”. 

Now the file “MyBallot-fixed.csv” is ready to upload to the IEEE MyBallot system as the final resolutions of the comments in this letter ballot.

10.4.6 Recording satisfaction/unsatisfaction of voter

This section needs to be re-written by someone who has actually used the ACRT, and knows how to use it efficiently. While the following will work, it is extremely cumbersome.

After opening the MSAccess ACRT, press “Comment Resolution Screen” on the Start menu. Under “filter records by status” select “Hot topic: TR/ER/GR unsatisfied” and click “Apply Filter/Sort”. It is also possible to select only one CommenterName by entering “CommenterName=”xyzzy”” in the additional filter criteria, but that requires knowing exactly how the commenter’s name appears in the database. Find the comments being accepted using PgDn. Click the button “Closed” for ones that the commenter finds acceptable, and leave unchanged the ones he/she does not. Pressing PgDn (or clicking the right arrow on the bottom status line of the window) moves to the next comment.
10.4.7 Generating report of unsatisfied comments for ExCom

A separate report pdf file is generated for each ballot in which there are unsatisfied comments. So if there were three recirculations performed, there could be up to four reports (initial ballot, and each of the three recirculations). The following procedure is done for each of the ballots.

After opening the ACRT file for this ballot, click “Reports” on the Start menu. On the “Final Reports” menu, under “Sort records by” select “Clause, subcl, page, line”; under “Comment type list” select “Unresolved TR/ER/GR Comments”, and then click “Fancy Committee Report”. Print that report by clicking File->Print, select “Acobe PDF” as the printer, click “OK”, and provide a name for the output pdf file.

The collection of all pdf reports generated above, one for each ballot that contained unsatisfied comments, is included in the Chair’s report to ExCom for approval of the draft.
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� Drafts that are presented for Working Group ballots, and later for Sponsor Ballots, all are numbered Dx.0, with the value of ‘x’ monotonically increasing.  See � REF _Ref194377602 \r \h ��5.1� for further information about draft numbering.


� This is open for interpretation by the WG Chair.  In 802.11 it has never happened. Some Working Groups always do recirculations after the initial Sponsor Ballot (10-day ballots), regardless of whether the draft achieved 75% acceptance or not. Other Working Groups modify the draft and do another 30-day initial Sponsor Ballot.  The rules from IEEE-SA and LMSC are unclear on this issue.


� A point is 1/72 inch.  The template sets the line width to be 6 inches, or 432 points. The default size of a 3-column table is 108 points each; making the third column 216 points (432-108-108) uses the entire width of the page.


� There are three changes from the original MyBallot_V4p4 from 802.3: (1) page footer for the Fancy Committee report isn’t sufficient for the 802.11 documentation system. In the “Database” window click on “Reports” under “Objects”, click on “Committee report_Clause”, then click “Design”. In the page footer, move the footer boundary lower, adding 7 dotes below “SORT ORDER”.  Use the Toolbox to add Label for “Submission” on the left. Use the Toolbox to add Label for “John Doe, Some Company” on the right. (2) the sort order was wrong for the “Committee report_Clause”. With the Report Design still open from the first change, change “CommentID” (just above where “Submission” was added) to “Clause, Subclause, Page, Line”.  Somewhere in the dotted area right click, and on the popup menu select “Sorting and Grouping”. Change the list of Field/Expression to be Clause (Ascending), then Subclause (Ascending), then Page (Ascending), then Line (Ascending). Click the “X” in the upper right of the Sorting and Grouping window. Click the “X” in the upper right of the “Committee report_Clause: Report” window, and answer “Yes” to saving the changes.  (3) Affiliation is provided by the MyBallot system but not accepted by this tool. In the “Database” window click on “Tables under “Objects”, select “DatabaseMyBallotCsv”, and click on “Design”. Select the row “Category” and click Insert->Rows. On the newly inserted row, set Field Name to “Affiliation” and Data Type to “Text”. Click the “X” in the upper right of the window and answer Yes” to saving the changes. Click File->GetExternalData->Import. Select a CSV file generated by MyBallot and click “Import”. In the Import Text Wizard, select “Delimited” and click “Next”. Set Text Qualifier to double quote, set “First Row Contains FieldNames”, and click “Next”. Select “In an Existing Table” and select “DatabaseMyBallotCSV” and click “Next”. Then click “Advanced” and click “Save As”. Enter the Specification name as “MyBallot CSV Format Input”, and answer “Yes” to overwriting the existing spec. Then click “OK” in the Advanced window, and “Finish” in the Import window.


� See recommendation a) in the instructions in the Excel template: “Always start a new document using the template, rather than using someone else's document.”  Wink wink.
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SELECT TildeDataFormat.CommentID, TildeDataFormat.CommenterName, TildeDataFormat.CommenterEmail, TildeDataFormat.CommenterPhone, TildeDataFormat.CommenterFax, TildeDataFormat.CommenterCo, TildeDataFormat.Clause, TildeDataFormat.Subclause, TildeDataFormat.Page, TildeDataFormat.Line, TildeDataFormat.CommentType, cUnscrub(TildeDataFormat.Comment) AS Comment, cUnscrub(TildeDataFormat.SuggestedRemedy) AS SuggestedRemedy, cUnscrub(TildeDataFormat.Response) AS Response, TildeDataFormat.CommentStatus, TildeDataFormat.ResponseStatus, TildeDataFormat.Topic, TildeDataFormat.CreateDate, TildeDataFormat.LastModDate, TildeDataFormat.DispatchDate, TildeDataFormat.WrittenDate, TildeDataFormat.Accept_RejectDate, TildeDataFormat.Closed_UnsatisfDate, TildeDataFormat.VoterStatus
FROM TildeDataFormat;
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		Comment ID		Date		Comment #		Name		Email		Phone		Style		Index #		Classification		Vote		Category		Page		Subclause		Line		Comment		File		Must Be Satisfied		Proposed Change		Resolution Status		Resolution Detail		Other1		Other2		Other3
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		854700023		11/24/2005 18:41:14 GMT		1		WILKENS, ROBERT D		robwilkens@hotmail.com		5165794285		Individual		1		General Interest		Abstain - Lack of expertise		General		2		Intro		44		Says "Section Five Five" when should say "Section 5"				Yes		Change to just "Section five"										

		855700023		11/25/2005 20:27:10 GMT		2		KASTURIA, SANJAY		skasturia@teranetics.com		6507047686		Individual		1		Producer		Approve		Editorial		169		55A		17		The notation for the matrices is confusing. The _b qualifier on H, col_swap and row_swap adds no value. \n\nWhat is currently listed as H is solely of historical interest.\n\nMultiple zip files are unnecessary.\n\nProvide official URLs to post matrices.zip				No		Use the term H for the parity check matrix (in place of the currently used H_b). Remove the _b qualifier on col_swap and row_swap.\n\nWhat is currently listed as H is solely of historical interest. Remove reference to this.\n\nPut gen_802.3an.txt, H.txt, col_swap.txt and row_swap.txt into one zip file called matrices.zip (pick a different name if the editorial staff of the IEEE has a better recommendation).\n\nThe value of presenting col_swap.txt is not clear. If the task force agrees, remove col_swap.txt also.\n\nGet official URLs to post matrices.zip\nUpdate 802.3an private site to carry matrices.zip										

		923300023		12/08/2005 17:21:32 GMT		3		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		1		Producer		Approve		Editorial		46		45		3		45.2.1.59 change 'bit' to 'bits'				No		change 'bit' to 'bits'		Disagree		REJECT. 						

		923400023		12/08/2005 17:21:32 GMT		4		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		2		Producer		Approve		Editorial		51		45		1		Move Table 45-53 up out of the PCS section				No		Move Table 45-53 up out of the PCS section		Agree		ACCEPT. 						

		923500023		12/08/2005 17:21:32 GMT		5		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		3		Producer		Approve		Editorial		57		45		30		45.2.7.1.3				No		change 'bit' to 'bits' and change 'then bits 1.0.13' to 'then speed selection bits 1.0.13'										

		923600023		12/08/2005 17:21:32 GMT		6		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		4		Producer		Approve		Technical		58		45		40		This could be confused with base page reception				No		Change 'Page Received' to 'Next Page Received'										

		923700023		12/08/2005 17:21:32 GMT		7		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		5		Producer		Approve		Editorial		58		45		45		Missing space				No		change ')or' to ') or'										

		923800023		12/08/2005 17:21:32 GMT		8		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		6		Producer		Approve		Editorial		59		45		22		45.2.7.2.6 spell out '='				No		change '=' to 'equals' where appropriate										

		923900023		12/08/2005 17:21:32 GMT		9		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		7		Producer		Approve		Technical		60		45		3		This register is not 10GBASE-T specific				No		delete the first sentence and replace with 'The Link Partner (LP) base page ability register is described in Table 45-121.'										

		924000023		12/08/2005 17:21:32 GMT		10		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		8		Producer		Approve		Technical		60		45		38		Missing 16				No		change '7.4:0' to '7.16.4:0' and '7.11:5' to '7.16.11:5'										

		924100023		12/08/2005 17:21:32 GMT		11		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		9		Producer		Approve		Editorial		60		45		41		Redundancy				No		delete (Register 7.0)										

		924200023		12/08/2005 17:21:32 GMT		12		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		10		Producer		Approve		Technical		60		45		48		The LP base page register also needs to be examined to determine HCD				No		change 'examined by' to 'examined along with the LP base page register by'										

		924300023		12/08/2005 17:21:32 GMT		13		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		11		Producer		Approve		Technical		61		45		8		This register is not 10GBASE-T specific				No		change '7.4:0' to '7.16.4:0' and '7.11:5' to '7.16.11:5'										

		924400023		12/08/2005 17:21:33 GMT		14		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		12		Producer		Approve		Editorial		61		45		1		Missing 's'				No		On lines 1,2,36 and 37 change 'support' to 'supports'										

		924500023		12/08/2005 17:21:33 GMT		15		MARRIS, ARTHUR		arthurm@cadence.com		+44 1506 595104		Individual		13		Producer		Approve		Technical		62		45		38		45.2.7.9 This register is not 10GBASE-T specific				No		Reword to remove reference to 10GBASE-T										

		924600023		12/09/2005 23:24:18 GMT		16		KASTURIA, SANJAY		skasturia@teranetics.com		6507047686		Individual		2		Producer		Approve		Editorial		67		45.5		67		The introduction in 45.5 starts with the numbering 45.5.8. This should be 45.5.1				No		Change the numbering of the Introduction to 45.5.1 and adjust the subsequent subsection numbering										

		925200023		12/10/2005 22:17:36 GMT		17		GOERGEN, JOEL R		joel@force10networks.com				Individual		1		Producer		Disapprove		Technical								The current implementation requires 10watts to 15watts, as stated by most chip suppliers, thru 2007.  It does not look promising for multi-vendor solutions in the 2watt to 4watt range, thus making xfp or LRM type optics the only useable high density solutions.  It looks highly unlikely that 16ports or 24ports of 10Gbps twisted pair will be viable into 2008.				Yes		Identify a lower power solution using techniques that require lesser amounts of power so low cost - high density solutions are achievable by 2007.		Agree		ACCEPT. 						

		925300023		12/12/2005 14:36:01 GMT		18		KAROCKI, PIOTR		pkar@ieee.org		+48 (601) 474687		Individual		1		General Interest		Approve		Technical		77		55.1.3.1		14		This, and figure 55.6 - mismatch order of actions.\nFigure stands: get 64 bits, add control bit, scramble, aggregate 50 blocks\nText stands: "The resulting 65 bit blocks are assembled in a group of 50 blocks and scrambled."\nI don't know which one is correct...				No												

		931900023		12/16/2005 20:21:31 GMT		19		KAROCKI, PIOTR		pkar@ieee.org		+48 (601) 474687		Individual		2		General Interest		Approve		Editorial		159		55.9.4		17		Why full-stop? Change "Although there is no universal standard. The following maximums generally apply." to "Although there is no universal standard, the following maximums generally apply."				No												

		934900023		12/17/2005 02:40:18 GMT		20		BHUSHAN, RAHUL B		rahul.bhushan@st.com		602-485-6123		Individual		1		General Interest		Approve		General								Missing a stream structure like 1000BaseT - Clause 40.3.2....Figure 40-7.				No				Principle		ACCEPT IN PRINCIPLE. 						



		CommentID		CommenterName		CommenterEmail		CommenterPhone		CommenterFax		CommenterCo		Clause		Subclause		Page		Line		CommentType		Comment		SuggestedRemedy		Response		CommentStatus		ResponseStatus		Topic		CreateDate		LastModDate		DispatchDate		WrittenDate		Accept_RejectDate		Closed_UnsatisfDate		VoterStatus

		1		d, d		d		d				d		de		clksa		  CA				TR		tHIS SI ATE		hJKDS				X		O				2006-08-11		2006-08-11										



		Object Name		Object Type		Failure Reason		Time

		Globals		Table		Could not save the object		2007-05-22

		Globals		Table		Could not save the object		2007-05-22

		Globals		Table		Could not save the object		2007-05-22

		Main		Table		Could not save the object		2007-05-22

		Globals		Table		Could not save the object		2007-05-22

		Globals		Table		Could not save the object		2007-05-22

		Main		Table		Could not save the object		2007-05-22

		Globals		Table		Could not save the object		2007-05-22



		CommentID		CommenterName		CommenterEmail		CommenterPhone		CommenterFax		CommenterCo		Clause		SubClause		Page		Line		CommentType		Comment		SuggestedRemedy		Response		CommentStatus		ResponseStatus		Topic		CreateDate		LastModDate		DispatchDate		WrittenDate		Accept_RejectDate		Closed_UnsatisfDate		VoterStatus		MyBallotCommentID		MyBallotDate		MyBallotPage		MyBallotSubclause		MyballotLine		MyballotComment		MyBallotCategory		MyBallotIndex		MyBallotVote		MyBallotOther3		MyBallotFile		MyBallotMBS		MyBallotProposedChange		MyBallotOther1		MyBallotOther2		MyBallotClassification



		TypeList		Comment		Subject		Header

		[CommentType] In ("TR", "T")		All Technical Comments				

		[CommentType] In ("ER", "E")		All Editorial Comments				

		[CommentType] In ("GR", "G")		All General Comments				

		[CommentType] In ("TR", "ER", "GR", "T", "E", "G")		All Comments				

		[CommentType] In ("TR", "ER", "GR") AND [ResponseStatus] Not In ("C", "Z")		Unresolved TR/ER/GR Comments				

		[ResponseStatus] In ("O")		Response not yet written				

		[CommentType] In ("TR", "ER", "GR") AND [ResponseStatus] In ("C","Z")		Resolved TR/ER/GR comments				

		[ResponseStatus] Not In ("Z")		All comments except withdrawn comments				

		[ResponseStatus] In ("O","W")		Unclosed comments.				

		[CommentStatus] In ("D") AND [ResponseStatus] In ("W")		Ready for committee action				



		CommenterName		VoterName

		Dove, Daniel		

		Inoue, Yasuhiko		

		Booth, Brad		

		KAROCKI, PIOTR		

		GHIASI, ALI		

		BOOTH, MR BRAD J		

		HO, KEANG P		

		EPSTEIN, DAVID I		

		KOEMAN, HENRIECUS		

		BECK, MICHAEL A		

		MORALES, JOSE		

		LAW, DAVID J		

		KRAMER, GLEN		

		Bob S		

		Piers Dawe		

		Grow, Robert		

		Barrass, Hugh		

		Law, David		

		Ganga, Ilango		

		D'Ambrosia, John		

		Thaler, Pat		

		Geoff, Thompson		

		McClellan, Brett		

		Valliappan, Magesh		

		McConnell, Mike		

		Marris, Arthur		

		Brad, Booth		

		Beck, Michael		

		Magesh , Valliappan		

		None entered		



		VoterName		VoterStatus		Vote

		_unknown		O		



SELECT Main.*, Main.Clause, Main.CommentType, Main.Subclause, Main.CommenterName
FROM Main
ORDER BY Main.Clause, Main.CommentType DESC, Main.Subclause, Main.CommenterName;

SELECT DISTINCTROW *
FROM ClauseList;

SELECT DISTINCTROW *
FROM TypeList;

SELECT DISTINCTROW *
FROM Globals;

SELECT DISTINCTROW *
FROM ClauseList;

SELECT DISTINCTROW *
FROM Dispatch;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Rough;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM Rough;

SELECT DISTINCTROW *
FROM ClauseList;

SELECT DISTINCTROW *
FROM Main;

SELECT DISTINCTROW *
FROM VoterNames;

SELECT DISTINCTROW *
FROM VoterStatus;

SELECT Main.*
FROM Main
WHERE ((([Main].[CommentType])="TR" Or ([Main].[CommentType])="ER" Or ([Main].[CommentType])="GR"));

UPDATE Main
SET Main.ResponseStatus = "C"
WHERE (((Main.ResponseStatus) In ("W")) AND ((Main.CommentType) In ("E","T")) AND ((Main.CommentStatus) In ("A","R")));

SELECT Main.CommenterName, Main.CommentType, Main.CommentID, Main.Clause, Main.Subclause, Main.Page, Main.Line, Main.Comment, Main.SuggestedRemedy, Main.Response
FROM Main
WHERE (((Main.CommenterName)=[Input Commenter Name]))
ORDER BY Main.CommentID;

SELECT Main.CommenterName, Main.CommentType, Main.CommentID, Main.Clause, Main.Subclause, Main.Page, Main.Line, Main.Comment, Main.SuggestedRemedy, Main.Response
FROM Main
WHERE (((Main.CommenterName)=[Input Commenter Name]) AND ((Main.CommentType)="ER"))
ORDER BY Main.CommentID;

SELECT Main.CommenterName, Main.CommentType, Main.CommentID, Main.Clause, Main.Subclause, Main.Page, Main.Line, Main.Comment, Main.SuggestedRemedy, Main.Response
FROM Main
WHERE (((Main.CommenterName)=[Input Commenter Name]) AND ((Main.CommentType)="GR"))
ORDER BY Main.CommentID;

INSERT INTO Rough (CommentID, LastModDate, CommenterName, CommenterEmail, CommenterPhone, CommentType, Page, SubClause, Line, Comment, SuggestedRemedy, Response, CommenterFax, Clause)
SELECT CommentsCsv.[Comment #], Date() AS Expr1, CommentsCsv.Name, CommentsCsv.Email, CommentsCsv.Phone, CommentsCsv.Classification, CommentsCsv.Page, CommentsCsv.Subclause, CommentsCsv.Line, CommentsCsv.Comment, CommentsCsv.[Proposed Change], CommentsCsv.[Resolution Status], CommentsCsv.[Comment ID], Val(Left$(CommentsCsv!Subclause,(InStr(1,CommentsCsv!Subclause,".")-1))) AS Expr2
FROM CommentsCsv
ORDER BY CommentsCsv.[Comment #];

SELECT Main.*, [Main].[Page], [Main].[CommentType]
FROM Main
WHERE ((([Main].[CommentType])="TR"))
ORDER BY [Main].[Page];

SELECT Main.CommenterName, Main.CommentType, Main.CommentID, Main.Clause, Main.Subclause, Main.Page, Main.Line, Main.Comment, Main.SuggestedRemedy, Main.Response
FROM Main
WHERE (((Main.CommenterName)=[Input Commenter Name]) AND ((Main.CommentType)="TR"))
ORDER BY Main.CommentID;

SELECT Main.CommenterName, Main.CommentType, Main.CommentID, Main.Clause, Main.Subclause, Main.Page, Main.Line, Main.Comment, Main.SuggestedRemedy, Main.Response
FROM Main
WHERE (((Main.CommenterName)=[Input Commenter Name]) AND ((Main.CommentType)="TR" Or (Main.CommentType)="ER" Or (Main.CommentType)="GR"))
ORDER BY Main.CommentID;
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SELECT Main.CommentID, Main.CommenterName, Main.Subclause, Main.Page, Main.Line, Main.CommentType, Main.CommentStatus, Main.ResponseStatus, Main.Comment, Main.SuggestedRemedy, Main.Response, Main.Topic
FROM Main;
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